Jump to content
The Uniform Server Community

UniServer Zero Controller Menu > General > Mail Utility msmtp


Recommended Posts


Server OS: Windows XP SP3 (with latest updates as at 21-Sep-2013)

UniServer Zero Modules installed:

Zero_Controller_10_2_3.exe (with msmtp v1.4.31)









Problem Description:

In general, no significant problems - great product, thank you.


Except problems with Mail Utility msmtp when trying to run it from the controller application, Menu > General > Mail utility msmtp > Send Mail (button).

Problem is: No mail is sent, no C:\UniServerZ\core\msmtp\msmtp.log file is created.

(I had previously appropriately edited C:\UniServerZ\core\msmtp\msmtprc.ini using Menu > General > Mail utility msmtp > Edit configuration file and double checked that the edits had been saved, and stopped and restarted the controller)

Sending mail using C:\UniServerZ\core\msmtp\Send_test_email.bat works as expected (does not matter if Apache Server is running or not running)

Sending mail using a PHP script works as expected when Apache Server is running.



(1) Edited C:\UniServerZ\core\msmtp\Send_test_email.bat and changed the line,

msmtp --file=%cd%\msmtprc.ini user_name@target_email_address -t < %TEMP%\temp.mail

such that 'user_name@target_email_address' was a valid email address

(2) Ran the file Send_test_email.bat from the Windows command prompt

(3) Everything worked as expected, log file created (and contents shown in controller General > Mail utility msmtp > log file

(4) Tried again to Send Mail using the controller General > Mail utility msmtp > Send Mail, but nothing appears to happen

(5) From the controller Apache Utilities > Server Console



C:\UniServerZ>msmtp.exe -P
ignoring system configuration file C:\Documents and Settings\All Users\Application Data\msmtprc.txt: No such file or directory
ignoring user configuration file C:\UniServerZ\msmtprc.txt: No such file or directory
falling back to default account
msmtp.exe: account default not found: no configuration file available

C:\UniServerZ>msmtp.exe -S
msmtp.exe: account default not found: no configuration file available


Thank you.

Link to comment
Share on other sites

Thanks for a very informative post. You have highlighted a bug, which I can confirm. The bug in the controller in addition I found minor issues with Send_test_email.bat and msmtprc.ini


These have been corrected in the new controller Zero_Controller_10_2_4.exe

Download the new controller and give it a spin.


All the best


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...