Jump to content
The Uniform Server Community

Problems with the connection to the Socket


Recommended Posts

I'm having issues trying to connect to MySQL using phpMyAdmin, this is the error:


I search on google and i can't find the files than requeired to be modify according to the answers there writed.

i also, have this other problem too:


i must say than, i try to fix that other problem changing versions, but it just continue to happend, i think both problems are connected, but i don't know exactly how, and i don't know how to fix them either.

Any help, comment, request for clarification and/or suggestion than improve the question would be much apreciated too.

Thanks in advance

Link to comment
Share on other sites

  • 2 months later...
  • 3 years later...


I also have these two problems (error phpmyadmin's incorrect parameters; check host, username, password + impossible to change the root password fonctionnality ← what is the mysqladmine.exe command line running? + "ERROR 2003 (HY000): Can't connect to MySQL server on '' (10022 "Unknown error")" when launching mysql console).
I add, that a nestat -ano shows that mysqk_z.exe is listening on, and that the mysql.err log has ...no error:

200426 14:35:52  InnoDB: Waiting for the background threads to start
200426 14:35:53 InnoDB: 5.5.41 started; log sequence number 1595675
200426 14:35:53 [Note] Server hostname (bind-address): ''; port: 3306
200426 14:35:53 [Note]   - '' resolves to '';
200426 14:35:53 [Note] Server socket created on IP: ''.
200426 14:35:54 [Note] Event Scheduler: Loaded 0 events
200426 14:35:54 [Note] D:\Orion\UniServerZ\core\mysql\bin\mysqld_z.exe: ready for connections.
Version: '5.5.41'  socket: ''  port: 3306  MySQL Community Server (GPL)."

I've installed\tested the versions 11_0_1_ZeroXI.exe, 11_6_0_ZeroXI.exe, 11_7_7_ZeroXI.exe, 11_7_8_ZeroXI.exe, 11_8_1_ZeroXI.exe, 11_8_2_ZeroXI.exe, 14_0_1_ZeroXIV.exe ==> I've got the same messages.

ps: my hosts file contains only one line ( localhost), I've searched to verify that I have only one my.* file which is the one present in the UniServerZ directory, and I've uninstalled any other program that would have a distant relation with mySQL.

==> Any idea how to investigate further ☹️ ?





Link to comment
Share on other sites


Being on "Windows 7 starter" (win. 32 bits), I've decided to reset the TCP\IP stack, to find it again, as set by default by Microsoft.

So I ran the following commands...:

>ipconfig /flushdns

>netsh winsock reset catalog

... and after rebooting the computer, access to mysql and phpMyAdmin are allowed again (I suspect third party network traffic monitoring programs, which I've tested, to have modified the TCP\IP stack, and not to have restored it exactly as it was even after their de-installation)).

==> [SOLVED], for me anyway.


Link to comment
Share on other sites

  • 1 month later...

==> run msconfig.exe and uncheck the service in its "Startup" tab, or go to the services console and put the service in "manual start" mode. In short, if necessary, rather write a script to launch the firewall, instead of a script that stops it after it starts automatically.

Link to comment
Share on other sites

In my case, i may have applications as NetStat or WYSIWYG software (like TCPView), etc, telling me that the server is indeed started and listening on the port number 3306, i come to the conclusion, that as long as a Telnet cmd (on localhost:3306, or on does not respond i.e. does not communicate, then the socket may have been created but really in a "unstable" way, therefore unusable.



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...