Jump to content
The Uniform Server Community

#2003 - The server is not responding


Recommended Posts

Me and olajideolaolorun spent an entire night trying to figure this out. We could not figure out how to get around this. Basically MySQL will not start up when I ask for it to start running. We tried MANY things and nothing worked. We tried so many things, its easier just to post the conversation we had.


sachit: haha, alright... here's a quick story first to help you understand

sachit: my office hired a guy to do their database... guy was an amateur (hated codign and thought it was hard)... so he made it in filemaker pro

sachit: i hated it.... so i said i'd help design it again in mysql

sachit: so, i found WAMP and found your Uni Server and wanted to install it on my USB key

sachit: problem is... mysql doesn't work on it... i get the 2003 error

olajid: 2003 error?

sachit: i also gave in and tried installing it on my computer (apache, mysql and php) but i ccouldn't get them to work either.)

sachit: hold up, let me start it up again and see what it exactly said

olajid: soo you installed them singlely

sachit: well AFTEr i couldn't get uni server to work... i went and downlaoded each individiually to install on my computer (something i didn't really want to do)

sachit: well i installed the uniserver onto my USB

sachit: hit the START file

sachit: and the thing opens up in my browser....

sachit: NOW... how do i start running my php files ?

sachit: and if i click Run MySQL, i get:

sachit: » Security Alert! Possible Attack HTTP_REFERER is not localhost. but ''. To disable this warning go: /home/admin/www/cgi-bin/secure.pm

olajid: so the serveer do work.... just problem with mysql?

sachit: sorry, 2003 error was probably something else

sachit: yah i guess mysql is the problem

olajid: go to that file and put a # before every line in thsat file... thhe seecure.pm file.

sachit: and also... where would i put my files to actually have it working? (and can i install phpMyAdmin?)

sachit: see, the thing is... theres SEVERAL versions of that file

olajid: phpmyadmin is already installed...

sachit: oh ok

sachit: ok ok... let me explain

olajid: there should only be one secure.pm in the W:/home/admin/www/cgi-bin/en/

sachit: G: is my USB key... when i run it, it starts another on W: (i assume thats the server)

sachit: oh ok... /EN/

olajid: they ar both the same thing...

olajid: g and w

sachit: i know, but the secure.pm file was what messed me up

sachit: did you type that error message?

sachit: cause you should add after /cgi-bin/EN

sachit: so i comment out the ENTIRE file to the bottom?

sachit: except the first line?

olajid: w ia a subst of g

sachit: heh... all these www, admin folders is kidna what made me drop programming and go into accounting

sachit: i used to work at nortel networks.... couldn't take it anymore

sachit: so i only have a basic highschool knowledge of this stuff which gets me by.... but i still like to do little simple projects

sachit: ok, so i clicked Run MySQL again and it is a blank page (with the header and side bar around it)

sachit: how do i know if its running?

sachit: if i click phpMyAdmin: Welcome to phpMyAdmin 2.6.4-pl4 Error MySQL said: Documentation #2003 - The server is not responding

olajid: oh ok

olajid: yap...

olajid: wee didnn't figure it was needed causee iits should bee autopmatiic tat you know what lang u are using and need to chnage..

olajid: lol..

olajid: :lol:

olajid: wait if iit is still loading..

olajid: l

olajid: k

sachit: i notice that there is no MySQL process running in the processes

olajid: go to C:/Windows/System32 and loook for this fiile in that folder.... LIBMYSQL.DLL

olajid: if you find it in there, delete it.

olajid: i hope you already uninstalled the single softwares you installed..

olajid: they are bound to cause troubles

sachit: ok, no libmysql.dll... and no i haven't uninstalled those

sachit: i'll do that now

olajid: please do it..

sachit: doing it

olajid: andn after that cheeck for that file.. libmysql.dll in C:/Windows and C:/Windows32

sachit: ok

sachit: and where do i put my files for them to work as a php file and stuff?

sachit: oh, and that 2003 error was happening BEFORE i installed them anyways

olajid: W:/www

sachit: oh ok

sachit: so i'm going to have to copy them there everytime or will they be saved there (ie, the usb key) ?

sachit: ohhh... is W: basically a "shortcut" to the folder already on my usb key of the same nature?

olajid: yap

olajid: they are the same thing

sachit: sorry for all these questions.... i uninstalled MySQL Server 5.0 and Apache 2.0 from the uninstall list

sachit: PHP wasn't there... do i delete that manually? (AND.... the Apache2 folder is still there, can i just delete that?)

olajid: yap

sachit: and the php.ini that i had to copy in the C:/Windows?

sachit: oh, and a suggestion... PLEASE change the scroll bars in your localhost page

sachit: it takes FOREVER to scroll down

sachit: ok, two things....

sachit: two things

sachit: :D

olajid: you mqan the admin panel?

sachit: yah

olajid: delete any php.ini in th C:/Windows folder

olajid: we know

sachit: yah i did

sachit: that in the next update?

sachit: heh, gets annoying having to scroll down

sachit: ok, phpinfo(), i can see mysql in there

sachit: but phpMyAdmin still gives me that error

olajid: restart your pc

sachit: alright, i'll be back in a second

olajid: kl

olajid: :D

sachit: alright, restarting the server

sachit: nope, same error

sachit: any idea?

olajid: check tthe process

sachit: what things should i b elooking for?

olajid: mysql.exe

sachit: nope not there

olajid: go to W:/local/mysql/ and click mysqlrun.bat

sachit: even when i click Run MySQL it doesn't appear

sachit: local doesn't exist

sachit: oh, found it under usr

olajid: ooops sorry

sachit: no problem....

sachit: clicked it... dos window popped up and disappeared

sachit: still nothing in processes

olajid: k... therte is something blocking iit...

sachit: hmm, any known programs that do that?

olajid: just 3ds max

sachit: nope, never have had that

olajid: are you sure you seearched the C:/windows and C:/windows/system32 folder for libmysql.dll/

sachit: yup, i even ran a search on my computer

olajid: also cheeck to make sure there is no fil caled my.cnf or my.ini or anything similar like my-small.cnf or my-small.ini in the C:/, C:/windows/, and C:/windows/system32 folder

sachit: i found my (configuration settings) in windows/

sachit: deleted that

olajid: k..

olajid: start it now

sachit: nope, no mysql.exe

olajid: u stqarted it?

sachit: yah

sachit: wait, no its not working

sachit: i TRIED starting it

olajid: do u know hoe to go to the seerviciees section of windows?

sachit: nope

olajid: go to run and type services.msc

sachit: you mean help and support?

sachit: ok i'm there

olajid: check and see if mysql is there

sachit: i see MySQLXY in there... and it says "Start the service"

sachit: thats pointing to the MySQL Server 5.0 which was previously on my computer

sachit: should i delete it?

sachit: wait, i can't... no delete button

olajid: yeah... thats the problem'

olajid: disable it

sachit: how?

sachit: oh ok, got it

sachit: nope, phpMyAdmin still gives me that error

sachit: and still no mysql.exe

olajid: u started it?"

olajid: go to the windows firewall exception list

sachit: ok

sachit: checked off is mysqld

sachit: and mysqld-nt

olajid: sorry bout that

olajid: are u there

sachit: checked off is mysqld mysqld-nt

sachit: there's like 4 Apache HTTP Server

sachit: only one is for uniserver

olajid: so they are checked?

sachit: i unchecked the others

olajid: make sure they ar all checked...

sachit: they refer to the old ones... i deleted them

olajid: is the new one therE?

sachit: if i double click, the route is to the old apache ones

sachit: yes, the uniserver one is there

olajid: ahh...

sachit: G:\Uniform Server\diskw\usr\local\apache2\bin\Apache.exe

olajid: createe a new exception for port 3306

olajid: tcp

sachit: name?

sachit: MySQL Fix ?

olajid: just mysql is okj

sachit: ok

sachit: nope... still nothing

olajid: do you havee annother mysdsql server running?

sachit: nope

olajid: wrong queestion

olajid: when u click mysqlrun.bat in the usr/local/mysql fioldeer... does it givee an error?

sachit: nope

sachit: just a dos window (blank) quickly pops up and closes

olajid: try restartiing again pleas

sachit: ok

sachit: one second

olajid: :)

sachit: hey

sachit: yah, no luck getting it started

sachit: i disabled my antivirus and firewall

sachit: nothing

sachit: although TWO Apache.exe come up everytime i start the uniserver

olajid: i tthink somethiing is blockiing it...

sachit: yah

olajid: just dont know what

olajid: go to command prompt

sachit: yup

olajid: typ netstat

olajid: tpe netstat -n and also netstat -a

olajid: you are looking for port 3306

sachit: npoe, not there

olajid: in all 3 of the commands

sachit: nope

olajid: doo u use remote desktop connection?

sachit: yah sometimes

: ~You have invited olajid to start Remote Assistance. Please wait for a response or cancel (Alt+Q) the pending invitation.

olajid: wrong on

: ~You have canceled your invitation to start Remote Assistance.

sachit: how do i send you an invitation for that?

: ~You have invited olajid to start Application Sharing. Please wait for a response or cancel (Alt+Q) the pending invitation.

: ~You have canceled your invitation to start Application Sharing.

olajid: canceel the crrent one

olajid: i do not have windows messeenger installed so i do not know if it will work

olajid: but lets try it

sachit: ok, how do i do it?

sachit: i found the little application... but i don't knwo hwo to send you an invitiation

olajid: donnt worry..

olajid: wont work

sachit: oh

olajid: try and download a new copy and run it

sachit: ok

sachit: i just delete it off myusb key right?

olajid: yes

sachit: its extracting

sachit: nope, same thing

Link to comment
Share on other sites

Do you have SAM installed? Search your whole PC for LIBMYSQL.DLL.... You should only find it where Uniform Server is, if you find it elsewhere, delete it.

Link to comment
Share on other sites

Do you have SAM installed? Search your whole PC for LIBMYSQL.DLL.... You should only find it where Uniform Server is, if you find it elsewhere, delete it.


I got no clue what SAM is, but I assume I don't have it. And I searched my entire computer for libmysql.dll and nothing.

Link to comment
Share on other sites


I too am getting a #2003 when I try to start MySql - nothing seems to happen. I've tried multiple times now, with the same result. What was the resolution on this issue after all - was there a resolution ?


Win98 environment, just installed Uniform Server - install seemed to go fine, didn't see any error messages. Doing a standard startup of US on W:.



Help ! (And thanks !)

Link to comment
Share on other sites

Which one are you guys using... the UPXed version? or the original? Search the PC for LIBMYSQL.DL, there should be only one and it should be in the Uniform Server folder....

Link to comment
Share on other sites

good.... There should be one there and only there....


Go to the Services.msc.... type it in, in Run.


Look for MySQL and tell me if you find it. Look for Apache also.

Link to comment
Share on other sites

I think we need to get that out of your System before MySQL will work.


K, go to the MYSQLXY properties and find the path it says its on.... put the patth in the code where i wrote 'PUT HERE'. Leave the '--remove' where it is, do not REMOVE it!


Open Notepad & Paste:


@echo off
echo Removing MySQL
net stop MySQLXY
PUT HERE --remove


Save it anywhere on your system and run.


If that does not work, try this code:


@echo off
echo Removing MySQL
net stop MySQLXY
usr\local\mysql\bin\mysqld-opt.exe --remove


This one has to be saved in the Uniform Server directory, where Server_Start.bat is.


Try and tell me what happens.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...