Jump to content
The Uniform Server Community

Palemoon proxy settings not consistent


Chipster.org
 Share

Recommended Posts

Friends,

I want all PaleMoon requests to go to my local Apache instance without any leakage to the Internet.

I know my Apache is configured correctly because when I submit the request "127.0.0.1:8088" I get results from my server.

In Palemoon, I can change the Preferences|Network to use a manual proxy server (as above) and everything works great until I close and reopen PaleMoon, when it defaults back to using the PAC file.

When I try to use a PAC file, I get inconsistent results, but they usually ignore the proxy and go out to the Internet.

My two options seem to be:

a.  make the manual proxy server settings stick

b. write a PAC file that only serves p content from my Apache instance

Any ideas as how best to do either of these things?

Thanks,

-- Cliff

 

Link to comment
Share on other sites

Oh, and the PAC file I'm editing is UniformServer/home/us_pac/proxy.pac

It reads,

function FindProxyForURL(url, host) {
  if (isPlainHostName(host)) {
    return "PROXY 127.0.0.1:8088";
  } else {
    return "PROXY 127.0.0.1:8088";
  }
}

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...