Jump to content
The Uniform Server Community

Server not visible outside intranet(port change)


Recommended Posts

I installed uniserver 3.3 yesterday and I ran into some problems getting the server to work from outside my intranet.


I setup my server on my home pc, which uses a wireless connection to connect to my wireless router, which connects via cable modem to the internet. I have dynamic ip but from past experiences, the ip address does not change very often.


Since I will be using this server on a port other than 80 (isp blocks outgoing 80), I have port forwarding setup to pass any incoming requests to my pc. I also have my pc setup as a dmz server in my router settings.


After copying the files for uniserver 3.3 on my computer, I ran server start.bat, which started the server and opened up a W drive. I then changed the .htaccess in my www dir to make the server public.


I directed my web browser to http://localhost which showed me the purple uniserver page. http://localhost/a got me to the admin panel 2.0. Under the apache configuration settings, the default setting for server was “localhost:80” which I changed to reflect my ip address followed by :8080 (this is the port I want the server to use).


After reading some other threads relating to this topic, I managed to change the httpd.conf file to reflect port 8080 in the listen port field.


I restarted the server at this point.


I then directed my web browser to http://localhost:8080 which resulted in a page not found error. I then tried http://localhost and I got the purple uniserver start up screen.

I don’t understand why this is happening. Since the server is using port 8080, I should not be able to connect to it without specifying the port.


I then asked several people to try connecting to my server using both urls above (with and without port). The result was no one was able to connect to the server.


I checked the apache status in the admin panel and I did not have any attempts to access the server. It looks like the requests are not making it to the server, but I am positive that the router settings are correct.


This is where I need help. I am stuck.

Link to comment
Share on other sites

Try another port like Port 81, and then access it with http://localhost:81


After that, shut the server down with Stop.bat and make sure it is not running still by tryn to access it again.


If that still dont work, restart your PC and then start the server up. Make sure you saved the httpd.conf file with the new change.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...