Jump to content
The Uniform Server Community

MySQL randomly shutting down and won't restart


Recommended Posts

i downloaded and installed uniserver with no problems, installed a phpBB forum over it, with a bit of help i managed to have others acces that forum. then begining with 3 days ago, while in the middle of browsing the fodum i get i error that said it can't acces the database. it was late so i just shut down and went to bed.


next day it worked, and during the evenning i installed postnuke on the server, ran it and started configuring it. when i changed the theme the second time, i got a php error, that i traced back to... yes.. no mysql server running. i clicked the run mysql link in the uniserver admin panel.. it said mysql running, then i tryed to open phpmyadmin... but it couldnt connect to the mysql server.


no mysql server appeared to be running on my compuer (i looked in services and tryed connecting to it with "mysql administrator"). i shut the server down, deleted it, rebooted, resintalled it, and ta-da, my sql worked. i reisntalled postnuke, and, again when i change my theme the second time, same error. that was yested late night, so i went to bed again.


this morning, i deleted unifrosm server and rebooted my compuer about 10 times.. but now, as soon as i reinstall the server and run it, then run mysql, the server just doesn't start. both phpmyadmin and the mysql administrator can't connect to the mysql server.


i tried shuting it down and starting it again, restarting it, forcing shutdowns of the server, deleted and rebooted a lot... nothing works... it doesnt make any sense, if it worked befre.. why doesnt it now.. and why did it randomly shut down while i was using it.... no i never had any other mysql installed on my computer, and that file you mentioned in the other thread doesn't exist on my computer.



Link to comment
Share on other sites

new development.. now the server won't shut down from the admin panel, is states


» Shutdown Server

Shutting Down Server


The server is shuting down.


Thank you for using The Uniform Server.


but it just stayed there and keeps running. this too worked before.

Link to comment
Share on other sites

W?hicih one did you download? Pleasee try downloading a new copy.. if you have the zip, try the exe. Also check to make sure the W:/usr/local/apachee2/logs/ diirectory is intact along with these:








BTW: Did you start anything before this happens? Try just testing it without installing the PostNuke... just to see if thats whats causing it...

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...