Jump to content
The Uniform Server Community

MySQL Innodb file locations ignored by XIII UniController


Recommended Posts

I am having a problem with the command line options that the XIII UniController provides when it launches the MySQL server.

I run a handful of Uniform Servers in parallel - mainly Coral 8.x.x servers and 1 XIII server. I have recently switched from a Windows 7 Pro (32-bit) laptop to a 64-bit laptop running Ubuntu, and Windows 7 Pro as a VirtualBox VM. The latter 2 OSes are both 64-bit versions.

For my MySQL databases, I have them centrally located in a file structure consisting of a single main directory with a sub-folder for each US server. Each sub-folder contains all of the MySQL databases used by that US server. As part of the laptop/OS change I have simply copied this file structure and files from my old SSD to the K: drive of my new SSD.


In order to ensure each server accesses the correct database(s), in the my.ini file for each MySQL server I have defined the location of the database files, using the following directives:






Each server also uses its own unique pair of port numbers for the Apache and MySQL servers.

I am trying to run the XIII server which I have called zero_xiii_sv0, the database files for which are located in the directory K:\WebServerFiles\MySQL_dbs\zero_xiii_sv0\data.

The directory K:\WebServers contains a number of sub-folders, with each sub-folder containing a single installation of a US.

The directory K:\WebServers\zero_xiii_sv0\UniServerZ\data is the default location for the database files created when the XIII server is installed.

The MySQL server my.ini file contains the following entries regarding file locations:

datadir = "K:/WebServerFiles/MySQL_dbs/zero_xiii_sv0/data/"

innodb_data_home_dir = "K:/WebServerFiles/MySQL_dbs/zero_xiii_sv0/data/"

innodb_log_group_home_dir = "K:/WebServerFiles/MySQL_dbs/zero_xiii_sv0/data/"

When the UniController is used to launch the MySQL server, the server is started using the following command string:


--defaults-file = "K:\WebServers\zero_xiii_sv0\UniServerZ\core\mysql\my.ini"

--tmpdir = "K:\WebServers\zero_xiii_sv0\UniServerZ\tmp"

--datadir = "K:\WebServers\zero_xiii_sv0\UniServerZ\core\mysql\data"

--innodb_data_home_dir = "K:\WebServers\zero_xiii_sv0\UniServerZ\core\mysql\data"

--innodb_log_group_home_dir = "K:\WebServers\zero_xiii_sv0\UniServerZ\core\mysql\data"

and I am unable to connect to the (ttrssdb) database.

As can be seen from the command string, the values of the data items:




are incorrect.

They should instead reference the databases in


instead of the default location of


I have tried running in a DOS session the Apache server with the correct command line string and that worked successfully, allowing me to attach to the correct database.

Am I missing something in the server configuration or is the procedure invoked by the "Start MySQL" button of the UniController simply ignoring the values provided in the my.ini file?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...