Jump to content
The Uniform Server Community

UniServer Coral and UniServerZ Running Wrong PHP Version


Recommended Posts

Hey folks,


I've been baffled and frustrated that I've been trying to update one of our servers that my supervisor installed and when I run any PHP installed module, it starts with wrong version of PHP. The server always starts with PHP Version 5.4.19. Regardless of what module I installed and checked that the files run with, it always starts with that version according to phpinfo. Server runs MS Server 2008 R2. My objectives are to 1) Update PHP to Version 5.6. and 2) Use ZeroXI controller for modularity of the server.


Here's what I've found and checked so far:

Supervisor installed two types of Uniservers while trying them out: Uniserver Coral don't know which version, but I tried updating to Coral 8.9.2... Initially, I uninstalled the original services but cannot verify (1) What is the name of the service in order to verify that? Also all of the apache and mysql modules are stopped and ZeroXI can peacefully start apache and mysql.


The other uniserver is Uniserver ZeroXI 1.1.6. Oddly enough, there was an installed service that wasn't running so I uninstalled that as well. I can verify that us_apache_1 service is not running. I installed php_5_6_0 which the documentation says that it supports. However, even if php56 is selected and phpinfo verifies that

Loaded Configuration File C:\uniserver\core\php56\php_production.ini


Apache Environment:

PATH C:\uniserver\core\apache2\bin;C:\uniserver\core\mysql\bin;C:\uniserver\core\php56;C:\uniserver\core\openssl;C:\uniserver\core\msmtp;C:\uniserver\utils;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Program Files\MySQL\MySQL Server 5.6\bin



extension_dir C:/uniserver/core/php56/extensions C:/uniserver/core/php56/extensions




Well, Apparently:

PHP Version 5.4.19

(2) Are there any other causes why the uniserver zeroxi uses 5.4.19 although it is set as php 5.6.0?


I have tried installing a new uniserver zeroxi controller under a different folder name, but to no avail, it consistenly still uses the same php version. Please let me know what other things that could point me to what is causing this.


Thanks in advance.

Link to comment
Share on other sites

Just to update what happened and our solution and this may apply to various WAMPP installations as well... We thought that

Configuration File (php.ini) Path


had nothing to do with our install of Uniserver. Apparently there is this errant php5ts.dll in the Windows folder. This file loaded the wrong version of php. As soon as we copied the dir/to/php/folder/php5ts.dll (c:\uniserver\core\php56\php5ts in our case), all of the modularity of unizerver zeroxi worked again.

For other WAMPP installs, you might want to check the same php.ini path in you phpinfo and if you have C:\Windows as the path, you can backup then copy the php5ts.dll file from the php installation folder to the Windows folder.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...