Jump to content
The Uniform Server Community

Basic Apache Configuration


Recommended Posts

Currently I run a production server on xampp with no real problems. I ran into a thread that mentioned your software so I wanted to see if I could use it as a usb alternative. That said, I am having difficulty getting uzoro to connect my site to the wan.


My Setup:

I have a fqdn and a port 81 noip redirect with noip.


In Basic Apache Config (BAC) I have added my registered domain name to Server name.

I have also installed wordpress into the www folder, created the database and WP install.

This allows me to login as www.mydomain-name.com through localhost.


I need to connect through port 81 so I change the listen port in BAC to 81 and when I do this I lose connection with the site altogether.


It appears that when I change the Apache listen port to 81, I see that uzoro appends the port# :81 to the url and it looks like this: www.my-domain.com:81 Now since my url already has a port 81 redirect silently added by noip I believe this causes the dns to see this as www.my-domain.com:81:81


I'm not having any luck finding what I'm doing wrong with this setup.

Can someone give me a little guidence as to what I am missing or doing wrong here?


Thanks for any assistance,


Link to comment
Share on other sites

I've looked this over pretty well and I'm fairly sure when you change the apache listen port it should not be appended to the URL above. This has to be an overlooked bug because it makes it pretty much impossible to use a registered domain name that has a port redirect on it unless I've missed some setting somewhere.

Link to comment
Share on other sites

"Now since my url already has a port 81 redirect silently added by noip I believe this causes the dns to see this as www.my-domain.com:81:81"

The above would be a logical conclusion however when you changed Basic Apache Config (server name and listen port) I assume you allowed EditHost to update your hosts file. This inserts a entry into the Hosts file " your_domain_name". When you enter your_domain_name (no port) into your browser the domain is resolved locally, port 80 is assumed and fails. However if you add port 81 the domain is again resolved locally and the page correctly displayed.

I assume the above is the problem you are seeing. To force external domain resolution proceed as follows, from UniController click the "Extra tab" and click "Edit Win hosts file". In the pop-up click "yes" allow changes to this computer. A new form is displayed, click on your domain name in the right window and click delete.

Now when you type your domain into the browser it is no longer resolved locally instead it is resolved by noip which adds port 81.

All the best

Link to comment
Share on other sites

Thank you for your help Ric,


I didn't realize that when I changed the Apache config port the program automatically set a line in the hosts file so I deleted the line and it now does allow me to see the page externally.



The basic steps I took are these:

1) Edit Basic Configuration

Server name = "mydomain.com" also add Server Admin Email

(Change Listen port set to 81)


2) Extra Edit Win Hosts File

Delete the Hosts entry for myDomain.com


3) Access and Passwords

Password Disabled (for now)

Set to "Local, Intranet and Internet Access"


>>> start Apache Server <<<

Local page FAILS to resolve

Try URL from a separate remote system (no :81 in url) (SUCCESS! system connects remotely :D :D :D)


Try URL again from local system but remove the :81 from the URL

SUCCESS! (system connects locally :D :D :D but :81 had to be removed)




Bottom line... and just to be clear, when I stop and restart Apache, on start it automatically brings up (or tries to bring up) the page locally and fails with port 81 automatically attached to the local url UNLESS I remove the :81 from the local (mydomain.com) URL and try again it resolves just fine (I assume) because it is doing so over the internet though my noip redirect just like any external system would. This means I can not connect locally unless I change my ip back to 80 for that moment to do so.


I don't think this is a bad thing because I could certainly work around it but I just want to be clear about it.

Do I have this correct?


Thank you very much for your courtious help.



P.S. donation coming :)

Link to comment
Share on other sites

I thought I had it licked. Not sure what happened but I'm getting a sever rejected connection message. I've reinstalled it several times, don't think I'm missing anything but no luck. I'm going to have to give up unless you can give me some advice.


I can get localhost fine but no remote and yes the hosts file does not have a redirect in it. The htaccess files are # out, I just don't understand what is going wrong, it all looks so simple.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...