Jump to content
The Uniform Server Community

Adding LDAP extension to PHP in Coral 8.6.7


Recommended Posts

Trying to add LDAP extension.


Using Uniform Server v8.6.7 on w2008 server with apache 2, php 5.4.8


LDAP DLL is uncommented in php.ini

extension directory is correct but has forward slashes (the dll is in the directory already - from the original Uniform install - so assume it is correct version)


php info does not show ldap working


apache error log shows cannot load dll - only clue is possibly the forward slashes though may have missed something else


changed forward slashes to back slashes and restart apache


now error log shows cannot load dll from directory with double backslashes

Error (same as forward slashes):

PHP Startup: Unable to load dynamic library 'W:\\UniServer\\usr\\local\\php\\extensions\\php_ldap.dll' - The specified module could not be found.\r\n in Unknown on line 0


searched various posts here and on other forums and also tried to understand php docs to no avail.


tried disabling another extension and that did not change either.


Can only think we are missing a simple switch somewhere to enable extensions etc


does Uniform server come with some kind of armoring (like ubuntu) to prevent system changes?



Link to comment
Share on other sites

went to php website and downloaded 5.4 and replaced the php_ldap.dll just in case - still no change to error


do not think it is the backslashes. Running out of ideas now.


Any help gratefully received.


Link to comment
Share on other sites

Added LDAP module in Apache and checked LDAP is on in the server configurator.


Still no joy.


It seems that the UNiform PHP is ignoring its own php.ini somehow even though the phpinfo for Uniform suggests it is reading the correct file.

Link to comment
Share on other sites

After some time digging further I cut my losses and upgraded to latest version Coral 8.8.7 -


When enabling the LDAP extension we got a different error -


missing libsasl.dll


searched again and found this for older version of Uniform Server (v7)




though apparently in later v7 Orion release this bug was fixed - see -



Perhaps it has reappeared somehow as the dll was missing from my download.


Either way ldap now appears in the phpinfo page and we eagerly anticipate being able to use it.


Hope this helps somebody else.


Is there some way to mark this as resolved?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...