Jump to content
The Uniform Server Community

t1lib with Uniserver


Recommended Posts

Supplement: I have learned that there's a bug with T1LIB excluded in PHP 5.0.4, which was fixed in release 5.0.5.

Therefore, how can I upgrade UniServer to 5.0.5; I have tried this already, but I end up with extesion .dlls load error (though it seems to me that I have changed all paths in php.ini - is there any other config file that i have missed ;) )

I look forward to any help.

Link to comment
Share on other sites

Please where can i get further information on the T1LIB. Never actually heard about it. Is it integrated into PHP? Is it an extention?


We all learn something new on daily basis :lol:



Link to comment
Share on other sites

Please where can i get further information on the T1LIB. Never actually heard about it. Is it integrated into PHP? Is it an extention?

I am not an expert in this matter but I belive it is a libraray that is supposed to be integerated. In PHP manual (at php.net) thare are described functions as:imagepsbbox, imagepscopyfont, imagepsencodefont, imagepsextendfont, imagepsfreefont, imagepsloadfont, imagepsslantfont, imagepstext.

They all need a compiler directive --enable-t1lib (i am not entairely certain how use this and i really would like to avoid compiling php source).


And here is a description of t1lib form (http://gnuwin32.sourceforge.net/packages/t1lib.htm):

t1lib is a library written in C which implements functions for generating bitmaps from Adobe Type 1 fonts. It uses most internal parts of the Type 1 rasterizer provided with X11R5 and newer but tries avoid the disadvantages known from that rasterizer. Although most people would use the rasterizer under X11, having X11 is not necessary at all. The rasterizer is implemented as a shared or static library to be linked to the programs that want to use Type 1 fonts. In addition to this library there is a test-program called xglyph which, as the name indicates, requires X11. It can be used to show most of the features of the library. xglyph can be run out of the box without doing any X11 configuration like setting resources.


Note: As You surely have noticed I am interested in Windows-based solution.


Thanks for Your interest, :lol:

Link to comment
Share on other sites

Hmm i see, i also did a read up after that reply and check on Google for more information. Currently right now i am very busy so i can't do this things i am about to ask you to do in order to help you, :lol: :)


A. Download the package of PHP you are using from http://www.php.net, if you are using 3.2a, you are using PHP 5.0.4, for others, please check to make sure as i do not remember them of head here. Please download the compressed zip package for Windows and not the EXE.


B. After download that same package from the php.net website, unextract it and look in the extension folder for php_t1lib.dll or anything similar...


C. If there is something similar, please reply to this post so we can continue on how to help you help yourself, :D sounds cool. :D



Link to comment
Share on other sites

First of all, I would like to thank you for Your kind help :) I really appreciate Your guides.


I have followed Your instructions (even before I have started this topic, since I do tried to solve this problem by myself :D ), but I haven't found any extentsion that would appear as relevant. In fact in PHP 5.0.4 archive, I have received only those extentions that are commented in UniServer's php.ini file.


However as I have mentioned before, during my research on web I have found a description of a bug concerning T1lib, that is : http://bugs.php.net/bug.php?id=32809


The last comment over there is: "

This bug has been fixed in CVS.


Snapshots of the sources are packaged every three hours; this change

will be in the next snapshot. You can grab the snapshot at



Thank you for the report, and for helping us make PHP better.


T1LIB support is now available on Windows."


So I have also downloaded this snapshot and as I have compared those two versions PHP 5.0.4 and 5.0.5, there is a significant size diffrence in php_gd2.dll file [792kb to 916kb]. It seems to me that having a newer version of this file in PHP 5.0.4 might solve my problem (but it's just my guess).


However, as You have pointed this out in some other topic of this forum, mixing the files from two different compilations is not possible (what i have also checked, just for experiment sake :lol: - and definitely You were right )


As such my conclusion is: migration to PHP 5.0.5 might help. Unfortunattely my skills fail in this matter. If You could help me in this matter or maybe find another solution :D

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...