Jump to content
The Uniform Server Community

Need help with OSCMAX on Production Site


Recommended Posts

Ive been struggeling for over 6 months to get my OSCMax (an OScommerce variant) off my dying LAMP server and onto a new WAMP server using Uniserver. I want to install Uniserver, Install OSCMAX with the intention of immediatly going live with the site. No localhost stuff. I've tried installation several times but when I go to the OSCMAX catalog page it loads fine, but if I navgate from that page I get a white screen. The same thing happens in the OSCMAX admin panel. I can load the login screen, but after login, I get a white screen.




here is some parameters

host name is - store

domain is www.mywebsite.com

FQDN is store.mywebsite.com

What should the servername be in apache's hppd.conf ?

If I change Uniserver/Apache's servername entry from localhost to www.mywebsite.com:80 , I get a 404 error trying to log into phpmyadmin. I also cannot install OSCMAX when it askes for hostname in the MySQL setup page and put in - store. It only accepts the name localhost.


I found a link to someone with the exact same problem::


At the very bottom of the bugtrack was the following which I did do but still get the same results.


"This is not an issue with osCmax, nor an issue with uniform server. Once you understand the requirements of your setup, installation is very easy with just a few added steps prior to running the installer. There are instructions for how to install on a non suPHP web server in the wiki. In short, you need to manually rename the configure.php.new files to configure.php. Then set the permissions of the admin admin/includes and catalog/includes directory to writable in windows explorer."


I found I can navegate to a linked page in the catalog by doing the following.

Let's say I'm on the first page of the OSCmax catalog. The http:// address reads:

http://www.mywebsite.com/catalog/index.php I get a blank white page. If I change it to

http://localhost/catalog/index.php the page loads.


Any help would be greatly appreciated, as after 6 months of stuggleing I'm at my wits end!

Link to comment
Share on other sites

Your setting in OSCmax, do they have localhost or http://yourwebsite.com in them?


When it works under http://localhost/ look at the source and see if the css and co links are localhost or how are they defined?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...