Jump to content
The Uniform Server Community

Load ADODb Drivers


Recommended Posts

I'm getting an error saying the IfNull function is undefined in my sql statement (need to put in an empty string for nulls). The function runs from the adodb.inc.php file. My best guess right now is that for some reason the ADODB drivers are not loading. I've confirmed they are referenced in the php.ini files and that the .php extension is referenced in the httpd.conf file. I loaded all the adodb files into the PHP folder. I'm hoping this is just a simple mapping issue. I'm loading it at the top of the file as -



(I also tried it with the path as - 'W:\usr\local\Php\adodb.inc.php'. Both versions worked until I added the function.)


The sql statement pulled the data fine until I added the function. It is -


$sql = "SELECT PartNumber, PartDesc, IfNull(Serial, ""), PartModel FROM Parts"

$rs = $conn->Execute($sql) or die("Error in query: $query. " . $db->ErrorMsg());


Is there something special needed for using ADODb with UniformServer?



Thanks in advance for the help.

Link to comment
Share on other sites

I have never tried it with Uniform Server but i do know that the file: W:\usr\local\Php\adodb.inc.php is not in that folder, unless you added it.


I will try and see, make sure it is loaded in the php.ini file and also the my.cnf file in W:\usr\local\mysql\bin


Hmm.. is this function a MySQL function or PHP function? Trying to figure something out.



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...