Jump to content
The Uniform Server Community

Control panel won't load a second time


Recommended Posts

If I close the Uniform Server main control panel, and then try to load it again, it won't load. I need to log out or restart my machine to be able to load the control panel.


Repro steps:

- I load Uniform Server (Coral 8.6.4) using Start_as_program.exe

- Main control panel loads. I can turn on Apache and MySQL, use my server, all is good

- When I'm done with the server I turn off the two services and close the control panel

- If try to run Start_as_program.exe again, nothing happens. Panel does not load.

- If I log out and back in, or restart my machine, I am able to load the main panel and all is good again.


This is happening to me consistently, not a one-off thing.


My system:

Windows 7 64-bit

Coral 8.6.4


Not sure what other relevant info I can provide. Nothing shows up in error.log or access.log.


edit: I did a bit more testing, and figure out that this only occurs if I shut down the two services before closing the panel. If I leave the two services running, I can close and re-start the panel as many times as I want.

Link to comment
Share on other sites

  • 2 weeks later...

mint_waxed -


Thanks for the persistence :) ... I was experiencing this as well, however, mine occurred intermittently and I could not reproduce. I too was always stopping both before closing; I will now try your method and just close ;)

GeneratePress / Elementor / WP Show Posts / Do It Yourself WordPress - Sniffle Valve


You want a WordPress website and you want it now - GOOD CHEAP FAST WEBSITES


Don't take life too seriously ... nobody has ever gotten out of it alive :)


Link to comment
Share on other sites

FYI, this is most likely because mshta.exe, the program that interprets the HTML code for Unicontroller, doesn't shut down properly. I found that this may happen if you rush the menus by trying to stop them early. Since it's not easily repeatable, I can't say for sure.


What I do if Unicontroller will not restart is to fire up the task manager and kill of the mshta.exe that's still running. It's one of the reasons that Ric is moving to a totally new control program for Steel-9, the next major upgrade.


Hope this works in your case.




Link to comment
Share on other sites

  • 6 months later...

Thanks a lot BobS!


A have a similar problem which was driving me nuts.


I'm using Coral 8.8 with Windows 7 32. Tried both Run as Program and Run as Service. Nothing happened and didn't get any error message whatsoever.


Killing mshta.exe solved the problem.




PS. Is there an error log file somewhere which would have informed me what the problem was?

Link to comment
Share on other sites

  • 1 month later...
  • 9 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...