Jump to content
The Uniform Server Community

Problem with Sqlite3 extension


Recommended Posts

I've enabled php_sqlite3.dll in my UniServer.


However, when I try to add a database in phpliteadmin, it fails, even though the extension is installed. Also, no error message appears, and it says that the program can't diagnose the problem and it also says I should contact the person who wrote phpliteadmin.


I even tried the program Adminer, but it says this error message.


"Please use one of the extensions db, sdb, sqlite."


The db and sdb extensions aren't installed in php. I tried looking in the access and error logs and nothing was shown. The pdo SQLite extension is disabled too.


So I've got an extension that doesn't seem to cooperate with PHP. What do I do?

Link to comment
Share on other sites

There are two PHP extensions that require enabling:






"Please use one of the extensions db, sdb, sqlite."

These are not PHP extensions they are file extensions you provide when saving a database file e.g. test_db.sqlite


All the best


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...