Jump to content
The Uniform Server Community

Run on virtual drive


Recommended Posts

If I use either these options:




Then Apache crashes.

Reason appears to be:

What should be "w:/" in the httpd.conf file is entered as "w://" throughout the file.


(temporary work-around) Works if I do this:

- stop Apache (Hit "Stop Apache" button in the program window)

- replace all "w://" with "w:/" in the conf file

- hit "Start Apache"



also, line 48 of disk_start_stop.vbs has an apostrophe missing before the comment



using v8.4.0




Excerpt from /alt_diag/run_on_virtual_drive/read_me.txt

If you wish to run The Uniform Server from a folder containing spaces in its path.


Option 1:

Copy files run_on_drive_w.bat and remove_drive_w.bat to folder UniServer.

To start the servers from folder UniServer, double click file run_on_drive_w.bat


Using this file creates a virtual drive named W with folder UniServer mapped to

its root (top level). This eliminates spaces at the expense of dedicating a

drive letter.


Option 2:

Copy file disk_start_stop.vbs to folder UniServer.


To start servers from folder UniServer, double click file disk_start_stop.vbs

A list of available drive letters is displayed. Either use the default letter

or enter one of these available drive letters. Click OK, which creates a virtual

drive and runs the servers.


Note 1:

The above methods are suitable only for running servers as a standard program.

Do NOT use these methods when installing servers as a service.

Link to comment
Share on other sites

More trouble.


After edit of the httpd.conf file to change w:// to w:/, and restarting UniServer using "run_as_program" option (which worked fine prior to using the drive w option), that option now fails to get Apache working (Apache crashes though continues to show up as started).


Now also, i noticed, using "run_as_program" doesn't change the w:/ references to c:/ etc. in the httpd.conf file (even after doing "remove_drive_w.bat" first). I then did "run_as_program" through a fresh install of UniServer in a separate folder, but no go there either, though the httpd.conf file in that install has the c:/ and not w:/ references.


If I run it using "run_on_drive_w", Apache seems to work fine then.


Will see later if a reboot re-sets things to normal... but what's going on otherwise?

Link to comment
Share on other sites

First off, thanks for pointing out the error on line 48 of disk_start_stop.vbs.


Second, I found that the servers start properly using "run_on_drive_w.bat" without any changes. Running "remove_drive_w.bat" worked correctly as well. I copied them to the UniServer directory as specified in the instructions. I also didn't need to do any editing of httpd:conf.


Using disk_start_stop.vbs appears to work properly as well, except that I found it sometimes leaves mshta.exe running.

The likely problem is that when removing the virtual drive, the mshta.exe is left in limbo, and doesn't terminate, which causes any subsequent scripts to not work. I don't know of a workaround for this, except to use the Task Manager to kill it off.


Note that the server path (W:\ in this case) is tracked in uni_con\config_tracker.ini and MUST match all the path statements. If it's out of sync, you end up wit a broken server stack. So editing the httpd.conf to change the paths was probably not a good idea....




Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...