Jump to content
The Uniform Server Community

Using the Unix 'tar' Command

Len Jacobson

Recommended Posts

I have a line of code that invokes the 'system()' function, and the command passed to the 'system()' function is the 'tar' command. This code works perfectly when I run it on my (Linux) production server; when I run it on the 'Uniform Server', I get an empty file as its output.


Can anyone tell me why this doesn't work and if there is a way to make it work?


Thank you very much.


(This addendum I am adding several hours later.)


My question is ridiculous. I realized shortly after posting my question (when I was no longer at home near my computer) that the 'system()' command can only execute Windows commands. Since 'tar' is not a Windows command, there is no way my code could work on the Uniform Server.


Sorry for bothering people with this query.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...