Jump to content
The Uniform Server Community

Uniserv 7. Apache doesnt start.


Recommended Posts

So it looks like you have a portable server and you tried to start it on Windows 7/Vista. Yep, that requires admin privileges.




Link to comment
Share on other sites

The thing is i tried administrator rights before and failed because i didnt notice that the first click only installs the services and you have to click at the same position again to start the services. So i made all right but not both together and failed. :(


Maybe a warning would be nice. I know what admin rights are but many wouldnt even know it.


By the way... i have read what Version 8.0 is but im not sure if it is a better version 7 or less than version 7 because its coded new from the ground. So should i update or would i miss something? At least it has its own and less addons than v7 isnt it?

Link to comment
Share on other sites

Why deprive yourself? Get them both! :(

You can use the MultiServer capability in either one to change the ports and have both running together on the same machine. Just change the name of the UniServer directory, or install it as a subdirectory (eg., C:\Coral_8\UniServer). Experiment along with us and then you'll be ready for anything!




Link to comment
Share on other sites

I dont get it... Now i cant stop Uniserv...


I wanted to add a new vhost. For that i created an entry in the hosts-file like this: buy...online.local www.buy...online.local


The ... are replacements only for not posting the url.


Then saved the hosts-file successfully.


Then i had uniserv started and localhost showed the standardpage. After that i edited httpd.conf and added:



<VirtualHost *:80>

ServerName buy...online.local

DocumentRoot L:/Tools/Software/Entwicklung/UniServer/_projekte/buy...online

ServerAlias *.buy...online.local

DirectoryIndex index.html index.php



The adminpanel shows me that the new host is active. But when i type in buy...online.local then it shows only uniserv standardpage. The other vhosts work.


So i thought i need to restart the server. I tried but i cant stop the server... o.O


When i run Serverstatus it shows me:


================== UNIFORM SERVER STATUS ==================


Your Internet IP Address = xx.xx.186.xx

Accessible from Internet = NO

Cron run status = Not running

PHP INI: php.ini file = Production




Apache port = 80

Apache SSL port = 443

Apache executable name = Apache.exe

Apache service name = ApacheS1

Apache SSL server = Disabled

Apache run status = Not running

Apache install status = Free to install




MySQL port = 3306

MySQL executable name = mysqld-opt.exe

MySQL service name = MySQLS1

MySQL run status = Not running

MySQL install status = Free to install




Apache port = 80 In use by another program.

Apache SSL port = 443 Is free to use

MySQL port = 3306 In use by another program.



So it says its not on but used by another program.


When i start precheck it states:


=== Port in use test ===


Port number = 80

PID = 7544

Process name = Apache.exe

Path to process = "L:\Tools\Software\Entwicklung\UniServer\usr\local\apache2\bin\Apache.exe"


Port number = 3306

PID = 6660

Process name = mysqld-opt.exe

Path to process = L:\Tools\Software\Entwicklung\UniServer\usr\local\mysql\bin\mysqld-opt.exe



To start Uniform Server above ports must be free.


Either stop-uninstall offending application.


Move Uniform Server to different ports.


So uniserv is blocking the port. And i guess the vhost doesnt work because that instance is working with an old httpd.conf.


So how can i stop uniserv now?


When i use alternative control and stop_server it states:


MySQL Server not running.


Apache Server not running.


Cron not enabled in config.inc.php


Even started as admin.


The same result with service stop uninstall:


MySQL is not installed as a service


Apache is not installed as a service


Whats happening? How can i stop uniserv?


By the way... when using the taskbarmenu its confusing that you can click the same command more than once while the command isnt finished already. For example starting the server takes some time. But the menu isnt blocked and there is no sign that uniserv is still working on that command except i can see a higher cpu-usage. But still... can i setup a block of the menu or at least a message or something that shows me if the command has come to an end or not?




Link to comment
Share on other sites

It looks like i cant do anything anymore.


I now have 2 portable installations. Coral and UniServ 7.


When i wanted to start coral as program the start apache was gray. So i looked into windows services and found the services ApacheS1 and MySQLS1. Both are set to automatic.


So i thought i should deinstall them. I used the alternative control. It couldnt do so.


Then i disabled both services and tried service_stop_uninstall again. It said the services arent installed.


Then i started coral again as program. I wanted to start and mysql couldnt be started while apache isnt active too. Only the gif is moving all the time without stopping.


Then i tried it as service but its not working too.


And now i cant use program or service in coral because no window is opening.


When i start uniserv 7 as admin i can start and stop the server but i cant deinstall the services.


Even though i restarted the pc.


How can i delete the services?


At least i can use uniserv 7 again but... coral looks much more userfriendly :(




Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...