Jump to content
The Uniform Server Community

Bug reporting Orion 7.0.8


Recommended Posts

Hi people,


I've been using UniServer since it was called UniformServer with no issues at all until now.


Recently, I was using version 5.6.5 Nano but I decided to update, went to Orion 7.0.0 and used it on a pen drive, and later I downloaded version Orion 7.0.8.


I have two computers where I use UniServer to develop my PHP-MySQL driven Websites. One computer has Windows 7 Enterprise installed and the other one has Windows XP Home Edition, and the pen drive is formated as FAT32. This is important, I think, as you'll see when I explain what happened.


I ran Orion 7.0.0 on my FAT32 512MB pen drive which is connected to my Windows 7 Enterprise with no problems. I clicked "start.exe" and then I started all the services. No questions asked.


Point 1. But then I downloaded and tried to use Orion 7.0.8 on local folder of my Win 7 Enterprise PC, and then the trouble began.


When I run "Run_pre_check.exe" an warning message says "Warning: file_get_contents UniServer/home/admin/www/includes/.version : failed to open stream.". Even so, I clicked "start.exe" and started the services. Windows asked me to allow Apache and MySQL in the Windows Firewall Dialog box. I said 'yes' to both questions. Apanel comes up, PHP is running and then I went to phpMyAdmin... An error says that phpMyAdmin cannot start and to check the webserver log or PHP errors.


I read online that this was maybe a folder permission issue due to a new version of MySQL. I gave read/write permissions to "Everyone" on my computer in the folder /home/admin/www/includes/ and then phpMyAdmin works. But none of my PHP scripts that reads data from the DB does its work, the pages always come up blank. No errors shown, even with error_reporting set to E_ALL.


Point 2. If I try to run Orion 7.0.8 on my pen drive or on a local folder of my WindowsXP Home Edition computer, the same warning appears when I run "Run_pre_check.exe", the same error shows when I go to phpMyAdmin, but due to the fact that WindowsXP Home Edition has no "Security" tab on folder properties I can't even change or give read/write permissions.


Point 3. My pen drive is connected to my Win 7 PC, but because it was formated as FAT32 and not NTFS, there's no "Security" tab on folder properties to change/give permissions...


This meaning I have to go... back to Nano 5.6.5... or Orion 7.0.0.


Can anyone help me on this issue? Is this a bug? Older versions worked.


Thanks in advance!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...