Jump to content
The Uniform Server Community

admin and phpmyadmin give 403 error


Recommended Posts

I installed Orion 7.0.6 on an XP VM running under Virtual box, and it all worked just fine - still does.


Then I moved the whole /UniServer/ directory and all its contents onto a Small Business 2008 server - and Apache is serving my content, and php is being processed correctly, so my application works fine.


But the admin functions and phpmyadmin all give a 403 error. (When run on the main console and when run via LogMeIn).


Can someone guess what is wrong, or point me in the right direction to discover the problem?





Link to comment
Share on other sites

Soem more data.

The error log entry is like this


[Thu Jun 02 11:11:47 2011] [error] [client ::1] client denied by server configuration: C:/Orion/UniServer/home/admin/www/, referer: http://localhost/


The relevant entry from C:\Orion\UniServer\usr\local\apache2\conf\httpd.conf is


Alias /apanel "C:/Orion/UniServer/home/admin/www/"
<Directory "C:/Orion/UniServer/home/admin/www/">
 Options Indexes Includes
 AllowOverride All
 Order allow,deny
 Allow from all


The .htaccess file in C:\Orion\UniServer\home\admin\www contains


Order Deny,Allow
Deny from all
Allow from
Allow from localhost
AddHandler cgi-script .bat .exe .pl .cgi
Options +ExecCGI

(and commented lines).


I have restarted Apache.


And I still get 403 errors froim http://localhost/apanel on Server 2008, when logged in as administrator on the consol.


Has anyone any idea what is happeneing? I've lost what littel hair ai have left. B)


Link to comment
Share on other sites

Cracked it!


IP6 is enabled - and localhost in IP6 is ::1 not - and both definitions were in the hosts file with ::1 coming last.


I have commented out the IP6 definition of localhost and all works as expected. B)

Link to comment
Share on other sites

Hi, got the same problem after switching from Orion_7_0_1 to Orion_7_0_7 (probably missed a few versions).


The funny thing is - Opera has no problem to access localhost/apanel (or localhost/anything), while, for example, IE or Google Chrome get "403 forbidden" error.


I tried to figure out ian's solution but I couldn't.



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...