Jump to content
The Uniform Server Community

phpmyadmin throwing error on nano 6.5 & 6.6


Recommended Posts

Hi on the last 2 releases I am getting the following error with trying to access phpmyadmin (no changes to anything)


MySQL said:


#1045 - Access denied for user 'root'@'localhost' (using password: YES)


phpMyAdmin tried to connect to the MySQL server, and the server rejected the connection. You should check the host, username and password in your configuration and make sure that they correspond to the information given by the administrator of the MySQL server.


thanks, megan

Link to comment
Share on other sites

Hi Megan,

I could not reproduce the issue. :angry:


Only difference between versions is phpMyAdmin 3.3.2 and phpMyAdmin 3.3.3


On the new release zap folder:



And replace with corresponding folder from 5.6.4-Nano


If it resolves the issue I will check the differences, may have missed something. :angry:

All the best

Ric :)

Hey I am away this weekend hence may be Monday.

Link to comment
Share on other sites

  • 2 weeks later...

I apologize for taking so long to get back to you on this - was gone on vacation myself - so the thing is its been a while since I upgraded my uniform server and 6.4 is giving the same mysql access denied error when I try to go to phpmyadmin so I went back and checked my wordpress mini servers and they all work great - I am on XP and tried uniform server 6.4, 6.5, & 6.6 on both my C drive and my E drive and am getting the same result - I would think it was my mcafee antivirus except my mini servers work great - if it works for others then it must be some setting on my box - any suggestions on where I should look or what I should try???


Thanks Megan

Link to comment
Share on other sites

Hi again Ric - I did a little experiment and found that mysql allows phpmyadmin access (on my system) up to version 5.4 - when I go up to 5.5 then the access denied message occurs - thanks for any tips, Megan

Link to comment
Share on other sites

Hi Megan

That information is of real use it may help to pin-point the problem.

First what version of XP are you using?


This error suggest your MySQL server is running

#1045 - Access denied for user 'root'@'localhost' (using password: YES)


On version 5.6.6 run the following tests. I really want to know if MySQL is accessible from a command window.


1 Start servers as normal

2 Navigate to folder UniServer\alternative_control

3 Run “Start_MySQL_Console.bat” opens a command window

4 Type the following:

mysql -uroot –proot

You should see something like:


Welcome to the MySQL monitor. Commands end with ; or \g.

Your MySQL connection id is 11

Server version: 5.1.47-community MySQL Community Server (GPL)

Copyright © 2000, 2010, Oracle and/or its affiliates. All rights reserved.

This software comes with ABSOLUTELY NO WARRANTY. This is free software,

and you are welcome to modify and redistribute it under the GPL v2 license

Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.



If you get the above type: exit

Response will be: Bye


5 Repeate 4 with the following:

mysql -hlocalhost -uroot -proot


6 Repeate 4 with the following:

mysql -h127.0.0.1 -uroot -proot


Results should be identical for 4,5 and 6


Hopefully the results will pinpoint where to look.


All the best

Ric :angry:

Link to comment
Share on other sites

Ok took a bit of playing around but now I know what is going on - I have another mysql installed as a service and for some reason it is interfering with the mysql on nano after 5.4 - sorry about that - I guess I will just have to remember to stop the service if I want to use 5.5 or higher


sorry, Megan

Link to comment
Share on other sites

OK! It’s a port issue, try running move servers. Uniform Server will run along side existing servers.


All the best

Ric :angry:

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...