Jump to content
The Uniform Server Community
Sign in to follow this  
grrr

Missing my.cnf MySQL file.

Recommended Posts

Hello,

 

First posting and i guess as good as any moment to thank you for the greatest WAMP development tool i've ever seen.

 

But i do have (probably limited to just this) a small grief.

I noticed this problem after i tried to upgrade from the 5.3 to 5.4 server.

For some reason my php/mysql programming stopped working when trying to read/write to the MySQL database.

Not being very server inclined, i browsed the forums for a solution but didn't find any so i left it for the next version.

But now i tried to upgrade to version 5.5 and the same problem arose.

 

The server tray icon thingagy is working fine and starting both Apache and MySQL server was no problem.

I could even use PHPMyAdmin normally but when trying to run my php files with MySQL access, the result was no dice.

So this time i tried to fiddle around a bit more with the server package and then i suddenly tried from the unitray tool to select the edit configuration for MySQL function... and then got a modal screen showing me that taht file was non-existant.

So i tried to get an old my.cnf file and put in the usr/local/mysql folder and tried again but it's still not working.

 

Do you have any idea what could be the problem?

 

Thanks in advance.

 

[edit]

For some reason the server doesn't accept submitted form values and goes into a submission loop only to exit due to a timeout error.

Share this post


Link to post
Share on other sites

Looks like you have found a bug in UniTray :)

 

To resolve this edit file

UniServer\unicon\tray_menu\UniTray1.ini

Search for my.cnf replace with my.ini

The MySQL configuration was been renamed to my.ini

 

However there should be no need to edit the MySQL configuration file.

 

Check your “host” file contains a line

127.0.0.1 localhost

 

See Wiki for details

 

If that fails to resolve the problem can you post an example of code that fails to run on 5.5-Nano

 

All the best

Ric :)

Share this post


Link to post
Share on other sites

I guess i submitted two different problems.

One about the unitray issue and one about submitting form data.

Sorry about that.

Thought the issues were related and discovered them sequentially instead of simultaniously.

 

But i am pleased to announce that the problems have been resolved.

As i was looking at the downloads, i saw the 5.5a version instead of the 5.5, so i thought what the heck.

I can now normally submit form data into the mysql database again.

Changing the my.cnf to my.ini indeed resolves the unitray issue.

 

Thanks a lot for the fast response and hard work.

Share this post


Link to post
Share on other sites

Hi thanks for the update.

Unitary was a minor bug, had to fix all language packs and other plugins so as not to replicate it.

 

However I would still like to see code that fails on 5.5-Nano because 5.5a-Nano is a parallel version which uses the PHP 5.2 branch while 5.5-Nano uses PHP 5.3 branch

 

Hence I believe the real problem has not been resolved.

 

All the best

Ric :)

Share this post


Link to post
Share on other sites

I think i finally realized what i probably did wrong.

 

I used a form to submit data to the database but i changed the form removing file submission from the form but i forgot to change enctype property from multipart/form-data to application/x-www-form-urlencoded.

That's probably a good reason why submission of data failed although i'm not quite sure how forgiving the browser and apache are with mistakes like that.

 

Dumb mistake, i know.

 

Sorry for the inconvenience but everything is working fine now.

Share this post


Link to post
Share on other sites

No need to apologise we have all been down similar paths.

Anyway thanks for taking time to post, always nice to know what resolved a problem and it also helps other users.

 

All the best

Ric :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...