Jump to content
The Uniform Server Community

#2003 - Can't connect to MySQL server on 'localhost' (10061)


Recommended Posts

Windows Vista 32bit , latest .exe of UniServer


I just downloaded and installed UniServer and get this error when I click on phpMyAdmin in apanel: "#2003 - Can't connect to MySQL server on 'localhost' (10061)"


I've checked and double checked the various passwords.


If I click on phpMyBackupPro it opens but displays this error on the Start page: "MySQL data is not correct!"


This _may_ be some kind of Vista only problem. I had WampServer installed initially and had mySQL working fine, then something happened and I ended up with that same error listed above. I could not fix it and found Uniform Server so decided to try it instead, but I'm getting the same error right out of the box.


I've searched the mySQL forums and can find no cure. I've dug thru every file I can find that has some reference to the mySQL name and password and everything looks fine.


Is it normal to see two instances of Apache.exe in Windows Task Manager when Uniserver is running? Is it normal to see mysqld-opt.exe still running in Task Manager after executing Stop.bat?


Any help is greatly appreciated.

Link to comment
Share on other sites

Actually, I'm on the 2nd install of UniSever. when it would not work on the first install I thought I did some thig wrong and deleted it and reinstalled it. So, I may have broken the first install somehow and it has remnants hanging around.


One thing that lends to this way of thinking: on the 2nd isntall, I can't recall exactly where it happened, but it would not accept my new password when I was doing the Security checks from the apanel main page. I had to change the user name also. I went from the originally show "root" to "admin".


Now, running mysql.exe from the command line, I find I can access it by using "root" but not with "admin". So, my new question are

1) where is the name stored for "root" that mySQL is seeing?

2) why did the 2nd install force me to change the name?


OK, I got it working by changing the name in apanel under Admin Panel Configuration.


I'd appreciate it someone could still answer my earlier questions so I have a better concept of how things are working.


Thank you. Nice product.


Ooops, I spoke too soon. phpMyAdmin is working now but phpMyBackupPro won't let me log in now. Could someone please provide a list of files and places where the names and passwords for the various products are stored so I can get them back in sync?

Thank you.

Link to comment
Share on other sites

phpMyBackupPro is store in the config.xxx.??? file in the include folder...


This may be because your other install of WAMP left just files... or maybe you still have that on the PC. Check C:/Windows and C:/Windows/System32 for LIBMYSQL.DLL

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...