Jump to content
The Uniform Server Community

phpmyadmin Access Denied.


Recommended Posts

I went through the tutorial on how to change the mysql password in the DB and in the password file and did this but it gives me an access denied page when starting phpmyadmin (I restarted the servers).


Now, I replaced the mysql database files and changed the password file back to where it was to no avail.


Then I downloaded a fresh copy of UniServer 3.5 and am using it exclusively and still cannot get into phpmyadmin and I have changed nothing. (Restarted computer and server) Can someone please help?


I have also noticed the weird bug about the url having all lowercase letters in it. It seemed to work one time with lowercase then doesn't work at all.



Link to comment
Share on other sites

Restart your browser, download a fresh version of US and start it. You should be redirected to the Admin Panel from there click on phpMyAdmin.


That should work, if it doesn't please tell us the error you get.


If it does work and you want to change the root MySQL password go to http://localhost/apanel and click on MySQL Setup. Type your new password in there and then stop the server using stop.bat close your browser (or tabs) then start it with server_start.bat


You have to close your browser and/or tabs to clear the cookie set by phpMyAdmin.

IPB Image


Link to comment
Share on other sites

Shame on me! I seem to have missed this post, thanks metaltailz I have corrected UniCenter accordingly.




Honest I do read the posts even if I am a bit late :D


All the best

Ric :D

Link to comment
Share on other sites

Thanks for the help guys. But here is what I have now. I changed the password in apanel and everything was fine. I added some users and assigned database privileges and so forth. Everything was working fine. Then I started debugging some php scripts and got an error that php could not access a database so I thought I'd go into phpmyadmin to reset the passwor to that particular database and get this error


#1045 - Access denied for user 'root'@'localhost' (using password: YES)


I shutdown that server and start a new one from a freshly unzipped version of the file and start a new browser session in firefox and still get the same error.


Is this an issue with my computer somehow? I can't imagine that if the password in the file is the same as the one in mysql that it wouldn't work. Oh by the way I tried to log into the php backup tool and it let me in with root and root which is the password on the mysql database so why can't phpmyadmin get in? phpmybackup did say the data for my mysql database was incorrect though I don't know what that means.



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...