Jump to content
The Uniform Server Community

UniServer3_4, DROP command denied to user 'root'@'localhost'


Recommended Posts

In the database mysql, user table, i had to to change the field Drop_priv for user root from N to Y in order to get rid of error message:


DROP command denied to user 'root'@'localhost'


Seems that N is a wrong default setting for this field?

Link to comment
Share on other sites

Initially the error came up when trying to install PHP-Fusion CMS.


Then tried to drop all of the PHP-Fusion tables via phpMyadmin, but got the same error message in phpMyadmin.


Changed N to Y to get rid of the error message both when running the PHP-Fusion installation and when trying to drop tables in phpMyadmin in general.

Link to comment
Share on other sites

Well, if you try to add the drop command like you would normally by editing privleges through phpMyAdmin you can't.


To get around this little bug, start the server, start MySQL. Open phpMyAdmin, you should see a bar on the side with a drop down menu. Click on it and select the database mysql, scroll down until you see a table called user, then click the browse button. You will then see a list of all the users, click on edit next to root. You will then see a list of all the privleges available to that user, just change the value of Drop_priv to yes.


You should now be able to use the drop command in MySQL.

IPB Image


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...