Jump to content
The Uniform Server Community

1146 - Table 'mysql.proc' doesnt exist


Recommended Posts

I think you have one of two problems!


1) If you are running a version of MySQL below version 5 you need to upgrade to 5.


2) OK so you are running UniServer 3.3 and MySQL is version 5.0.17

I ran a quick test and can confirm the mysql.proc error.

I think you need to run mysql_fix_privilege_tables.sql script to fix the problem.


Almost sure you need the correct version of the script to match 5.0.17


The script is not included with UniServer 3.3 and I could not find one on the net.


I pass this one over to Olajide I could be totally wrong. :lol:

Link to comment
Share on other sites

  • 3 weeks later...

Its a sql file, run it using phpMyAdmin.


i tried using the sql in phpmyadmin but gave me error:


SQL query:




MySQL said: Documentation

#1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'mysql_fix_privilege_tables' at line 1


what did i do wrong?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...