Jump to content
The Uniform Server Community

Can't get US to run on Windows 2000


Recommended Posts

Hi there,


Boy, I thought this would be easy, but unfortunately, it is quite frustrating.


I downloaded the latest version of US (3.3) on a Windows 2000 system, unzipped it to my USB stick (drive I:) and ran the Server_Start.bat.


Firefox opens to file "file:///W:/home/admin/www/redirect.html", I can see what appears to be a half loaded page with a purple background and "THE UNIFORM SERVER" logo at the top.


The page is constantly looping, ie. the browser can't seem to finish loading it. The browser throbber is constantly in motion, the status bar rapidly flip-flops between


'Waiting for localhost'






The apache error.log file shows multiple instances of a handful of lines, e.g.:


[sun Apr 08 21:52:07 2007] [error] [client] PHP Fatal error: Maximum execution time of 30 seconds exceeded in W:\\home\\admin\\www\\includes\\config.inc.php on line 14

[sun Apr 08 21:52:07 2007] [error] [client] PHP Fatal error: Maximum execution time of 30 seconds exceeded in W:\\home\\admin\\www\\index.php on line 15


[sun Apr 08 21:52:09 2007] [error] [client] PHP Fatal error: Maximum execution time of 30 seconds exceeded in W:\\home\\admin\\www\\includes\\.version on line 1


(i.e. there are multiples of these lines, a few seconds apart)


During this looping, the computer is pretty sluggish.


I see that drive W: is being created just fine.


Then I tried to apply the patch at http://center.uniformserver.com/uniserver/...op_problem.html, I visited http://localhost, http://localhost/apanel, with the browser still behaving in the same way, no matter what I did.


Previously, I always gave up and stopped Apache after about 30-60 seconds with the Stop.bat script.


But then, I just let it run its course (i.e. didn't stop Apache) and waited and after about 5(!) minutes the page http://localhost/apanel finally gets loaded.


This behavior is reproducible. Every time I run Start_Server.bat it takes 5 minutes for the apanel page to show in the browser.


After the initial 5 minute wait subsequent loads of http://localhost/apanel are without a delay.


How can this be fixed? What am I doing wrong?



Link to comment
Share on other sites

I have never used Windows 2000 I use either Windows XP home or XP Pro. The reason I mention this is because of your last statement it works (well after 5mins). Hence it is not the recursive loop problem you are seeing. You are running from a USB stick and state subsequent reads are OK.


I have observed a similar thing on XP and tracked the problem back to the USB stick. To confirm that this is your problem, create a folder on your C: drive and copy all of UniServer into it. Run UniServer from that folder after a short delay (not 5 mins) you will see apanel. If so try using a different USB stick and see if that makes any difference.



Link to comment
Share on other sites

Hi Ric,


Thanks for the reply.


Ok, I did not yet try what you suggested, but I think I can exclude the USB stick being the culprit. It's supposed to be a fairly quick one (cruzer; it was advertised as being suitable for games - whatever that means), but I'm not that knowledgeable in these things, so am not sure.


Anyway, this morning at work I plugged the USB stick into my office computer (XP Pro) and again started the Server_Start.bat script. At first, I saw again that the browser attempted to load the apanel page (the browser's status bar toggled between 'Waiting for localhost' and 'Stopped' just as observed on my Windows 2000 machine at home, but this time it only took about 4 seconds for the apanel page to show.


I have to admit that my Windows 2000 computer at home is not the fastest machine, but still it shouldn't take 5 minutes, should it?


So, I wonder if some process is not quite finished setting up when it takes 5 minutes from the USB stick on the Windows 2000 computer. Is there a way to check while the browser tries to load the apanel page?


I'll try again tonight and will look what processes show up in the Task Manager during those 5 minutes.



Link to comment
Share on other sites

That looks good, proves memory stick and UniServer are working (4sec on XP Pro).


I would still like to eliminate the USB / Win 2000 interface, hence the reason for running it from your C drive. If this is relatively fast, then it points to either the USB stick or possibly Win 2000 drivers. Do you run large programs from the stick on Win 2000 if so are these OK.


The initial long start up could be due to virus scanning (but 5Mins)


I have no experience with Win 2000 but I have this nagging in the back of my mind that’s screaming threads and environment. Do you have the right drivers for USB 2?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...