Jump to content
The Uniform Server Community
Sign in to follow this  
johntor

V56_UniServer_USB_1.0 bug with PAC?

Recommended Posts

I followed the instructions installing on USB. Everything seems ok. The problem is somewhere around the PAC file. I installed joomla into a virtual host the root folder is accessed normally but some links are messed up. for ex. a link http://testjoomla/ is converted to http://testjoomlahttp/ . An http/ is added to the end of the file. If I remove the decleration from pac\my_hosts.pac and insert it into windows hosts file then everything works fine. The problem is at work that I can't modify hosts. I'm not sure if this is a problem of portable firefox.

 

any Ideas suggestions?

 

Thank anyway!

J!

Share this post


Link to post
Share on other sites

I like to reproduce a problem! Hence this is my set-up:

XP-Home

 

1 Extracted UniServer5_6b.exe

2 Ran Server to check it works

3 Installed V56_UniServer_USB_1.0.exe

4 Created Virtual host jm.com in folder UniServer\www\joomlatest (Using Apanel)

5 Closed server

6 Extracted plugin V55_Joomla_1_5_15a.exe (note this was placed in folder UniServer)

7 Moved folder joomla contained in www to folder UniServer\www\joomlatest

8 Ran servers and typed in http://jm.com/joomla/

9 Checked links no issues found until I clicked the home link.

 

Yep you do get a double http:// :)

Two hours later and I have still not found the cause. :)

 

All the best

Ric :)

Share this post


Link to post
Share on other sites

I like to reproduce a problem! Hence this is my set-up:

XP-Home

 

1 Extracted UniServer5_6b.exe

2 Ran Server to check it works

3 Installed V56_UniServer_USB_1.0.exe

4 Created Virtual host jm.com in folder UniServer\www\joomlatest (Using Apanel)

5 Closed server

6 Extracted plugin V55_Joomla_1_5_15a.exe (note this was placed in folder UniServer)

7 Moved folder joomla contained in www to folder UniServer\www\joomlatest

8 Ran servers and typed in http://jm.com/joomla/

9 Checked links no issues found until I clicked the home link.

 

Yep you do get a double http:// :)

Two hours later and I have still not found the cause. :)

 

All the best

Ric :)

 

This is checked on Windows 7 and Windows XP

 

Here is what I did.

1 Extracted UniServer5_6b.exe

2 Ran Server to check it works

3 Installed V56_UniServer_USB_1.0.exe

4 I Create w: letter using subst like the old good days for the uniserver folder

5 Created Virtual joomlatest in folder w:\www\joomlatest (Using Apanel)

6 Created a db with phpmyadmin and I installed latest joomla following the proposed position

7 After installation finished I typed http://joomlatest site appears ok but the home link is http://joomlatesthttp/

8 edit manually hosts inserting joomlatest 127.0.0.1

9 remove option from firefox using my_hosts.pac (using default windows hosts)

10 Everything is fine.

11 Changing back to using my-hosts.pac

12 Problem is back

 

alternately

I go to the administrator panel. (http://testjoomla/administrator/)

make an error login then login ok. The url is: http://testjoomlahttp/administrator/index.php

and the output window says:

 

Not Found

 

The requested URL /administrator/index.php was not found on this server.

 

Further further more (after hours...)

Into my normal firefox installation i changed to use Automatic proxy configuration URL pointing to my_hosts.pac guess what THE SAME!

 

I tried Portable Firefox 3.5.8 no luck!

 

Thank you for your reply

J!

Share this post


Link to post
Share on other sites

I do admit, this is driving me nuts. :)

Not sure where or what the failure mode is.

Relative links works.

Absolute links seem to have that extra http

 

Its not isolated to a particular application.

It is reproducible on different browsers.

Seems not to be an Apache issue.

 

Ya! That means I will keep looking at this issue.

 

Just wondering if any other users have any ideas?

 

All the best

Ric :)

Share this post


Link to post
Share on other sites

I do admit, this is driving me nuts. :)

Not sure where or what the failure mode is.

Relative links works.

Absolute links seem to have that extra http

 

Its not isolated to a particular application.

It is reproducible on different browsers.

Seems not to be an Apache issue.

 

Ya! That means I will keep looking at this issue.

 

Just wondering if any other users have any ideas?

 

All the best

Ric :)

 

After all this research I made it seems to be a firefox bug. There's must be something sending when requesting from Apache using the pac hosts. Do you think we can get help from firefox team?

 

Thanks once again

J!

Share this post


Link to post
Share on other sites

A few steps down....

 

I made this simple script:

<?php
echo "<pre>";
print_r ($GLOBALS);
echo "</pre>";
?>

and I found difference

into [_SERVER] and [HTTP_SERVER_VARS]

Values into [REQUEST_URI] are different.

Using my_hosts.pac into [REQUEST_URI] is the full url while using widows hosts only the script name.

 

Keep on

 

J!

post-3864-1268396432_thumb.jpg

Share this post


Link to post
Share on other sites

I found a quick solution so that I can keep on my job!

 

I inserted the following line:

$GLOBALS[_SERVER][REQUEST_URI]="";

into index.php and administrator\index.php

 

Everything works fine!

 

Keep on the good work!

 

J!

Share this post


Link to post
Share on other sites

Tanks for posting a quick solution it will help others with a similar problem.

 

At the moment I don’t see a permanent solution other than adding your elegant solution. :)

 

All the best

Ric :)

Share this post


Link to post
Share on other sites

Sorry for the mistake the correct line is:

$_SERVER["REQUEST_URI"]="";

the other produces some warnings and is better not to be used.

J!

 

PS:always glad to help

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...