Jump to content
The Uniform Server Community
Sign in to follow this  
haichen

magento installerror

Recommended Posts

I try to install magento on uniserver.

 

So far I'm now:

- I changed my.cnf to add Innodb.

- I added an empty magento database with phpmyadmin.

- At php.ini the extensions

extension=php_pdo.dll

extension=php_pdo_mysql.dll are added.

the dll was copied to extensions.

- in http.conf

LoadModule rewrite_module modules/mod_rewrite.so

 

That are the necessary changes to install magento I think.

 

At the setup.php I'm at the point where everything should be installed.

But then apache is shut down and I find the following in the apache log:

 

[sun Apr 05 02:36:25 2009] [notice] Apache/2.2.11 (Win32) PHP/5.2.9-1 DAV/2 configured -- resuming normal operations

[sun Apr 05 02:36:25 2009] [notice] Server built: Dec 10 2008 00:10:06

[sun Apr 05 02:36:25 2009] [notice] Parent: Created child process 3244

[sun Apr 05 02:36:26 2009] [notice] Child 3244: Child process is running

[sun Apr 05 02:36:26 2009] [notice] Child 3244: Acquired the start mutex.

[sun Apr 05 02:36:26 2009] [notice] Child 3244: Starting 250 worker threads.

[sun Apr 05 02:36:26 2009] [notice] Child 3244: Starting thread to listen on port 80.

[3244] EACCELERATOR: PHP crashed on opline 6 of execute() at Z:\www\magento\lib\Zend\Db\Statement\Pdo.php:232

 

[sun Apr 05 02:37:06 2009] [crit] Parent: child process exited with status 3 -- Aborting.

 

 

If I try to comment EACCELERATOR in php.ini i get a read-error.

 

 

Hopefully someone can help.

Thanks a lot for this nice server and excuse my bad english.

haichen

Share this post


Link to post
Share on other sites

Try the following:

1] Enable Innodb

Edit file: UniServer\udrive\usr\local\mysql\my.cnf

Comment this line as shown (enables Innodb):

#skip-innodb

2] Enable modules in php.ini

Edit file: UniServer\udrive\usr\local\php\php.ini

The first line is already enabled; add the second line as shown

extension=php_pdo.dll

extension=php_pdo_mysql.dll

3] Enable mod_rewrite

Edit file: UniServer\udrive\usr\local\apache2\conf\httpd.conf

Remove the hash (#) as shown for this line:

LoadModule rewrite_module modules/mod_rewrite.so

4] Add missing php extentions

Download php-5.2.9-1-Win32.zip from http://php.net/

Save and extract to any folder

Copy file: php-5.2.9-1-Win32\ext\php_pdo_mysql.dll

To folder: UniServer\udrive\usr\local\php\extensions

Copy file: php-5.2.9-1-Win32\ext\php_pdo_sqlite.dll

To folder: UniServer\udrive\usr\local\php\extensions

Copy file: php-5.2.9-1-Win32\libmysql.dll

To folder: UniServer\udrive\usr\local\php

5] .htaccess

You need to add the following +FollowSymLinks for mod_rewrite to write new urls:

Edit file: UniServer\udrive\www\.htaccess

Add to line as shown: Options +ExecCGI +FollowSymLinks

6] Restart the servers and install magento

 

All the best

Ric :unsure:

Share this post


Link to post
Share on other sites

...

Save and extract to any folder

Copy file: php-5.2.9-1-Win32\ext\php_pdo_mysql.dll

To folder: UniServer\udrive\usr\local\php\extensions

Copy file: php-5.2.9-1-Win32\ext\php_pdo_sqlite.dll

To folder: UniServer\udrive\usr\local\php\extensions

Copy file: php-5.2.9-1-Win32\libmysql.dll

To folder: UniServer\udrive\usr\local\php

5] .htaccess

You need to add the following +FollowSymLinks for mod_rewrite to write new urls:

Edit file: UniServer\udrive\www\.htaccess

Add to line as shown: Options +ExecCGI +FollowSymLinks

6] Restart the servers and install magento

 

All the best

Ric :unsure:

 

Wow...That was it!

 

Thanks a lot !

:) haichen

Share this post


Link to post
Share on other sites

Wow...That was it!

 

Thanks a lot !

:) haichen

 

 

Hmm. Also need to change the:

 

max_execution_time = 30

 

to max_execution_time = 300

 

in php.ini or the Magento installation will fail before it finishes. In a horrible dramatic unresolvable manner requiring you to start again from scratch.

 

Eugh.

 

Also, most of the instructions above no longer apply to latest UniServer 8.6.6 version.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...