Jump to content
The Uniform Server Community

sudeepjd

Developer
  • Content Count

    34
  • Joined

  • Last visited

Community Reputation

0 Neutral

About sudeepjd

  • Rank
    Project Developer

Previous Fields

  • SourceForge ID
    sudeepjd
  • Main OS
    Windows 10

Contact Methods

  • Website URL
    https://papernapkincollection.com
  • Skype
    sudeepjd

Profile Information

  • Gender
    Male
  • Location
    Bangalore, India
  • Interests
    I love Code, Cook and Collect.

Recent Profile Visitors

1,645 profile views
  1. We do have Let's Enctypt in our UniformServer development pipeline. However, i am a little carried away with work at the moment to make many useful updates to UniformServer. We are looking for community developers who can help out. The code for UniformServer is on github https://github.com/iamola/uniserver and if you are able to an in Let'sEncrypt certs of let us know the procedure to, it would definitely help.. Thanks for your time.
  2. I don't think it is UniformServer that is the problem, but more of how the browser handles the query when typed into the URL. Should it treat it as text that it needs to search for, or should it treat it as a URL to get the web page? UniformServer is not part of this process. If you have Admin rights the Apache->Apache Vhost->Create Apache Vhost process would also work as well. When you set up a vhost, Uniformserver adds in the 127.0.0.1 Sitename to your hosts file automatically. For eg., if you set up len.com as the sitename on a vhost, and the folder is len-server, then typing in http://len.com in your browser should server the pages in the vhosts/len-server folder. UniformServer sets this up for you automatically.
  3. May I know what is wrong with the path? Looks correct to me. In general php_openssl.dll is stored in the C:/UniServerZ/core/php56/extensions directory. Can you please check where your php_openssl.dll is stored and let me know so that I can see the difference between the correct path and the one UniformServer is providing. Thanks.
  4. Len, Maybe the solution is simpler that I thought it was.. Have you tried http://laptop-test-server instead of just laptop-test-server in your browser URL? I tried this out and for some reason, the first time I typed in laptop-test-server, it took me to the search page, but after I used http://laptop-test-server it took me to the correct page and interestingly from then on, even typing laptop-test-server without the http:// worked correctly. Even so, setting up a virtual host would be better than creating a folder in www, when you want to use the same instance of UniformServer for multiple projects. What I do is to have Uniformserver set up the virtual host folders in vhosts and then go in and update the http-vhosts.conf file to have a latptop-test-server.localhost type subdomain for each of the vhosts I set up. That way I can have multiple projects each with a different subdomain running off the localhost This would leave the http://localhost tied in with the main www as well.
  5. Len, You should be able to add in Virtual Hosts using the Uniformserver interface itself.. It will automatically do all the configuration for you. Apache->Apache Vhosts->Create Apache Vhost If it still does not work, I will take a deeper look into it.
  6. Good that it is working !!! I suspect that the problem may be due to the time it takes for PHP to initialize and Apache using that process to serve pages.. Sometimes of you click on Phpmyadmin immideately on opening Uniform Server and starting Apache PHP may not have initialized yet and so you would see the code instead of the page itself.. If you still face the problem again, I can try and troubleshoot further.
  7. Since it is a new laptop, one of the pre-requisites for UniformServer is the Visual C++ Redistributable which may not have been installed as the laptop is new.. PHP depends on it to run. On your older systems you may have installed it or it would have got installed automatically from some other non-related software installs. You can get the Visual C++ Redistributables from https://support.microsoft.com/en-us/help/2977003/the-latest-supported-visual-c-downloads Even though you system is a 64 bit, Uniform server uses the 32 bit version of PHP and MySQL, so you will need to get the vc_redist.x86.exe file. If you are still facing the same problem after the installation of the Visual C++ Redistributable, please do let me know and I can see what else could be wrong. Thanks. P.S.: This is documented in the MUST_READ.txt file in the UniformServer installation path.
  8. Is VC Runtime 32bit installed? Sometimes that gives a problem if it is not.
  9. You are right.. The add-on has been removed by the author.. I will update this in the next release. For more information on http/2 you can check out https://icing.github.io/mod_h2/howto.html
  10. Look at your path.. If it has spaces in it, then UniController will not run.. Probably the folder you unzipped it to, or a parent has a space in the folder name, such as "Hello Test". If so, replace the space in the folder name with an underscore ( _ ) character and try again.
  11. The Uniform Server team is glad to announce a minor update to Uniform Server Zero XIV. This version of UniformServer Zero XIV v14.0.2 can be found ON SourceForge at https://sourceforge.net/projects/miniserver/ The UniformServer is now open source, the Controller Code is now published on github at https://github.com/iamola/uniserver The following modules that have been updated: Core Apache v2.4.43 from Apache v2.4.41 PHP PHP v7.4.5 from PHP v7.4.0 PHP v7.3.17 from PHP v7.3.11 PHP v7.2.30 from PHP v7.2.25 Databases No updates Database Administration phpMyAdmin 5.0.2 from phpMyAdmin 4.9.2 Adminer 4.7.6 from Adminer 4.7.5 The latest modules of Uniform Server are at https://sourceforge.net/projects/miniserver/files/Uniform Server ZeroXIV/ZeroXIV Modules/ Help Needed I would like to request for the following help from the community. If you find any bugs, please feel free to either post on the forum or raise an issue on github so we can track and fix them. If you can fix the bug, please fork the github repo and issue a pull request.
  12. I have a couple of questions to see if I can help you out with this. 1. Are you hosting this on your system or on a VPS? 2. You have stated that the website is working over HTTPS, but Wordpress is not, so if I understand a normal website hosted works, but Wordpress hosted does not. 3. Does a Wordpress site hosted without Https work? Thanks.
  13. Yes, UniformServer is built using the 32 bit versions of Apache, PHP and MySQL as well as all the other modules. However, we are thinking of moving this to the 64 bit versions given that most of the Operating Systems today are 64 bit.
  14. My apologies for the delay in replying to this thread... Uniform Server by default ships with php loaded as a module and not using FastCGI, However, UniformServer is built to be modular and you should be able to update it to run PHP over FastCGI using the Apache mod_fcgid module. To do this you will need to make the following changes: The Apache config file that loads PHP is in /core/apache2/conf/extra_us/php74.conf. Back this file up as it is using the php7 loaded as a module. Download the attached php74.conf which uses mod_fastcgi and loads php via it by mapping the .php files to the fcgid-script handler and setting the php-cgi path. You can replace the existing /core/apache2/conf/extra_us/php74.conf with the attached php74.conf after backing up the one you have. Download the httpd-fcgid.conf file (attached) and store it in the /core/apache2/conf/extra folder. This file gives the configuration options for fcgid module in apache. Rename the /core/php74/php-production.ini to /core/php74/php.ini. For some reason mod_fcgid only picks up the php.ini file with that specific name. The downside of doing this is that you can no longer control the php.ini using the Unicontroller which you normally can do from the PHP menu in UniController, so you will have to make any modifications to this file manually In the /core/apache2/httpd.conf file, you will need to change the Alias to ScriptAlias [Lines 405 to 415] to allow php to run otherwise since these are outside the DocumentRoot will give you a Forbidden error for those apps like PHPMyAdmin running in us_opt1 Restart the Apache server and PHP should now be running over FastCGI. You can confirm this by going to PHP->View phpInfo from UniController and under the Server API will show CGI/FASTCGI To answer the 2nd part of your question: You can change the php.ini config file (which you renamed in Step 4 above) to get what you want. You normally can change this directly from UniController PHP Menu, but since it has been renamed, it needs to be done manually. To enable cURL, openSSL etc you can do that by removing the ";" (uncommenting the line) in front of the /core/php74/php.ini for those extensions on lines 924 to 960 of the php.ini file. GD2 (line 928) and MBString (Line 934) are enabled by default. You can validate this on the PHP->View phpInfo, Extensions page. For allow_url_fopen in specific you can change the value to On on line 868. Please do let me know if you have any more questions or not getting PHP to run over FastCGI. Note: There is one caveat though that I can't seem to figure out myself... The mod_fastcgi seems to be spawning multiple processes of php-cgi.exe and does not get terminated when the script ends or when Apache is stopped, so this keeps filling up the memory. If you or somebody can help out here, to let me know which setting needs to be tweaked to prevent this from happening would help. php74.conf httpd-fcgid.conf
  15. Uniform Server needs to be Unzipped (Installed) to a location where there are no spaces in your filepath. Check the directory path into which you are unzipping UniformServer to. If there are any spaces in the path, remove those spaces or replace them with underscores. For e.g, If you have unzipped UniformServer to C:\My App\UniServerZ rename the My App folder to MyApp C:\MyApp\UniServerZ and run UniController again. It should work. All the best.
×
×
  • Create New...