Jump to content


Photo

Zero - Access phpmyadmin remotely


  • Please log in to reply
3 replies to this topic

#1 erickdeoliveiraleal

erickdeoliveiraleal

    Newbie

  • Member
  • Pip
  • 4 posts
  • Main OS: Windows 7

Posted 19 December 2013 - 01:18 PM

How to access phpmyadmin remotely in the Uniform Zero last version?



#2 Ric

Ric

    Project Manager

  • Admin
  • PipPipPipPipPip
  • 1,535 posts
  • Gender:Male
  • Location:Cambridge,UK
  • Interests:Electronics
    Internet in general
    Open source projects
  • SourceForge IDmpgcan
  • Wiki ID: Ric
  • Main OS: Windows XP

Posted 20 December 2013 - 08:12 AM

To allow unrestricted access to phpMyAdmin edit the following file:
C:\UniServerZ\home\us_opt1\.htaccess

Replace these four lines:
Order Deny,Allow
Deny from all
Allow from 127.0.0.1
Allow from ::1

With these:

#Order Deny,Allow
#Deny from all
#Allow from 127.0.0.1
#Allow from ::1

Restrict access using basic authentication. At the bottom of file .htaccess add the following lines:

AuthName "Uniform Server - Server Access"
AuthType Basic
AuthUserFile ../../htpasswd/phpmyadmin/.htpasswd
Require valid-user
Save file.

Now create a password file as follows:
Create a new folder C:\UniServerZ\htpasswd\phpmyadmin
Copy file  C:\UniServerZ\htpasswd\www\.htpasswd to folder C:\UniServerZ\htpasswd\phpmyadmin
Edit file C:\UniServerZ\htpasswd\phpmyadmin\.htpasswd change name (root) and password (root) as required.
Save file.

To access phpMyAdmin type the following into your browser:

http://your_domain_name/us_opt1/index.php

Supply name and password as set in the password file  C:\UniServerZ\htpasswd\phpmyadmin\.htpasswd

All the best
Ric



#3 arlanda

arlanda

    Newbie

  • Member
  • Pip
  • 7 posts
  • Gender:Male
  • Main OS: Windows 7

Posted 17 January 2014 - 11:41 PM

Hi Ric,

 

I have tried the instruction but I kept on getting the message:

 

"Forbidden

You don't have permission to access /us_opt1/index.php on this server."

 

I've tried:

 

http://localhost/us_opt1/index.php   <--- WORK

http://127.0.0.1/us_opt1/index.php   <--- WORK

http://192.168.1.123/us_opt1/index.php   <--- NOT WORK (Note: same machine)

http://mydomain.com/us_opt1/index.php   <--- NOT WORK

 

I've tried starting again from scratch using the default user (root) and password (root) and still have the same problem as when I was using a different password.

 

Thanks,

 

Devin



#4 pioha

pioha

    Newbie

  • Member
  • Pip
  • 1 posts
  • Main OS: Windows 7

Posted 30 July 2015 - 03:20 AM

Topic not fresh, but mayby usefull for somebody (becouse promblem isn't solved by others).

 

My solution for remote access to `Uniform Server` (and phpmyadmin):

Requirements:

  • Both computers (client and server) have the system Windows (in my case Win7 on client and Win XP on server)
  • I installed on the server (Win XP) `Uniform Server`.
  • Both computers are on the same network (they have the same class) 192.168.0.x
  • Client computer have IP 192.168.0.8
  • Server computer have IP 192.168.0.1

Todo:

  1. Edit file `hosts` on client computer
    U
    se Uniform Server panel (Main menu --> Extra --> Edit Win hosts file)
    - Host name -> input target domain (ex. mydomain.com)
    - IP Adress -> input target IP (ex.192.168.0.1)
  2. Edit file 'hosts' on server computer
    You should input the values:
    - Host name -> input target domain (ex. mydomain.com)
    - IP Adress -> input target IP (ex.127.0.0.1)
  3. Switch off Apache
    To enable 'virtual host' option.
  4. Add virtual host by Uniform Server panel:
    Main menu --> Apache --> Apache vhosts --> Create 
    Apache vhost
  5. Add domain folder (or use already created)
    Input values:
    - Root folder name -> myFolderForDomain (localized dafault into www/... of US's dir)
    - Server name -> enter domain witch have previously entered (in these example it is mydomain.com)
  6. For access by phpMyAdmin additionaly You should edit file `.htaccess` in US folder.
    Localisation these folder:
    home\us_opt1\ .htaccess

    and modifify line 'allow' and add IP 'client computer' separated by space like this example :
    #Order Deny,Allow
    #Deny from all
    #Allow from 127.0.0.1 192.168.0.8
    #Allow from ::1
  7. Restart Apache.
  8. Done  :)

 

​​






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users