Jump to content


"path" after I downaloded my site into uniformserver?

  • Please log in to reply
2 replies to this topic

#1 sascha


    Junior Member

  • Member
  • Pip
  • 11 posts
  • Main OS: Windows XP

Posted 17 August 2009 - 02:46 AM

this is my first time to do things like this. I wanted to test my site from internet in my uniformserver.
I downloaded my site folders and database, I imported database and now I should change paths in configuration file of Joomla. yesterday I didn't succeed, therefore I try now again and I ask for advice.
I suppose this path should be changed:
var $log_path = '/home/vol5/07x.net/blabla/htdocs/amb/logs';
var $tmp_path = '/home/vol5/07x.net/blabla/htdocs/amb/tmp';

here is my path (as you see, "F" means that I installed uniformserver in my USB):

1) so, what should I write in:
var $log_path = '
var $tmp_path = '

I suppose I should change and this:
var $dbtype = 'mysql';
var $host = 'sql108.07x.net';
var $user = 'blabla';
var $db = 'blabla_test';

2) here is what I think:
var $dbtype = 'mysql';
var $host = 'localhost';
var $user = 'root';
var $db = 'vebsajt';
var $password = 'Olala';
user in my database in uniformserver is "root", so I suppose instead of "blabla" it should be "root". database name in my uniformserver is "vebsajt", that's name which I created when i imported database from my website into uniformserver.
I made root password for database in uniformserver the same as I had in website, for example Olala.

so is this all what should I do in order that my transfering of website function normal in my uniformserver? I did it yesterday and I didn't have success.
I think I did everything what is necessary:

and just one more question: how to set my uniformserver to be activated in Firefox instead to be activated in Internet Explorer? when I start uniformserver, it is activating in IE and I hate IE :)

yeah, here is what I get:

mark( 'afterLoad' ) : null; /** * CREATE THE APPLICATION * * NOTE : */ $mainframe =& JFactory::getApplication('site'); /** * INITIALISE THE APPLICATION * * NOTE : */ // set the language $mainframe->initialise(); JPluginHelper::importPlugin('system'); // trigger the onAfterInitialise events JDEBUG ? $_PROFILER->mark('afterInitialise') : null; $mainframe->triggerEvent('onAfterInitialise'); /** * ROUTE THE APPLICATION * * NOTE : */ $mainframe->route(); // authorization $Itemid = JRequest::getInt( 'Itemid'); $mainframe->authorize($Itemid); // trigger the onAfterRoute events JDEBUG ? $_PROFILER->mark('afterRoute') : null; $mainframe->triggerEvent('onAfterRoute'); /** * DISPATCH THE APPLICATION * * NOTE : */ $option = JRequest::getCmd('option'); $mainframe->dispatch($option); // trigger the onAfterDispatch events JDEBUG ? $_PROFILER->mark('afterDispatch') : null; $mainframe->triggerEvent('onAfterDispatch'); /** * RENDER THE APPLICATION * * NOTE : */ $mainframe->render(); // trigger the onAfterRender events JDEBUG ? $_PROFILER->mark('afterRender') : null; $mainframe->triggerEvent('onAfterRender'); /** * RETURN THE RESPONSE */ echo JResponse::toString($mainframe->getCfg('gzip'));

#2 Ric


    Project Manager

  • Admin
  • PipPipPipPipPip
  • 1,535 posts
  • Gender:Male
  • Location:Cambridge,UK
  • Interests:Electronics
    Internet in general
    Open source projects
  • SourceForge IDmpgcan
  • Wiki ID: Ric
  • Main OS: Windows XP

Posted 17 August 2009 - 02:00 PM

I am assuming V5-Beta
var $log_path = 'F:\\UniServer\\www\\ambasada\\amb\\logs';
var $tmp_path = 'F:\\UniServer\\www\\ ambasada\\amb\\tmp';

Note: The above is not a portable solution. You can leave the lines as is and add a Constructor check out this page: http://wiki.uniforms...ano#Portability

var $dbtype = 'mysql';
var $host = 'localhost';
var $user = 'root';
var $password = 'root';
var $db = 'vebsajt';

Change default browser:
Run Firefox:
1 On the menu bar, click Tools, from the drop-down menu click Options
2 Click Advanced (top right), click General tab
3 Click Check Now (bottom right)
4 Select Yes to set Firefox as your default browser. (IE will not now automatically open)


This indicates you opened file index.php directely! To view your site:

Start Uniform Server and type the following into Firefox http://localhost/ambasada/amb/index

All the best
Ric :)

#3 sascha


    Junior Member

  • Member
  • Pip
  • 11 posts
  • Main OS: Windows XP

Posted 17 August 2009 - 03:16 PM

I did everything like you said, now IT WORKS!

1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users