Jump to content


Unable to run Coral Uniform Servers on Windows 7 Pro x64 VirtualBox VM

  • Please log in to reply
No replies to this topic

#1 thersander



  • Member
  • Pip
  • 2 posts
  • Main OS: Windows 7

Posted 31 March 2019 - 04:30 PM

I have recently changed my ancient 32-bit Windows 7 Pro laptop for a 64-bit replacement, and have chosen to run 64-bit versions of Ubuntu as the main OS with Windows 7 Pro as a VirtualBox VM, instead of running Windows 10 which came pre-installed.
On my old laptop, I ran a handful of Uniform Servers in parallel - mainly Coral 8.x.x servers. The file structure I used for the servers on the old laptop has been duplicated on the new SSD running the Windows 64-bit VM. I have therefore been able to copy as-is the old server file structure to the new SSD.
The Uniform Server I am trying to start is an 8.6.7/Coral version, but I am encountering the same problem with all of the other Uniform Servers I have installed (all of which are 8.x.x versions).
I have also installed the 2008 C++ redistributable as described here.
I tried separately with the 32-bit then the 64-bit redistributable, and with both installed.
However, I am unable to start either the Apache http or MySQL servers, using run-as-a-program or run-as-a-service. The message which is displayed in a dialog box is "Unable to start Apache server":
 Attached File  Screenshot - 2019-03-31, 17_51_00.png   14.8KB   0 downloads 
I have investigated starting the Apache server further using Procmon (from Sysinternals), and the correct http.exe appears to be located, but the server never attempts to launch. There are no diagnostics in the Apache logs or the Windows event logs. The same problem is encountered when trying to launch the MySQL server too.
Given that the old and new file structures are identical, and that the US servers ran successfully on the old structures, I can only conclude that something in the new underlying OS configuration may be responsible.
Can anyone suggest what the underlying issue may be, or suggest any other additional diagnostics which might help to pinpoint the underlying issue?
I am able to successfully run a XIII Uniform Server, and was planning to migrate from Coral to XIII. However, I am having a separate problem in running the XIII server for which I will raise a separate forum entry, so that option is not really a solution to my immediate problem.

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users