Jump to content
The Uniform Server Community

Unable to run Coral Uniform Servers on Windows 7 Pro x64 VirtualBox VM


Recommended Posts

I have recently changed my ancient 32-bit Windows 7 Pro laptop for a 64-bit replacement, and have chosen to run 64-bit versions of Ubuntu as the main OS with Windows 7 Pro as a VirtualBox VM, instead of running Windows 10 which came pre-installed.

On my old laptop, I ran a handful of Uniform Servers in parallel - mainly Coral 8.x.x servers. The file structure I used for the servers on the old laptop has been duplicated on the new SSD running the Windows 64-bit VM. I have therefore been able to copy as-is the old server file structure to the new SSD.

The Uniform Server I am trying to start is an 8.6.7/Coral version, but I am encountering the same problem with all of the other Uniform Servers I have installed (all of which are 8.x.x versions).

I have also installed the 2008 C++ redistributable as described here.

I tried separately with the 32-bit then the 64-bit redistributable, and with both installed.

However, I am unable to start either the Apache http or MySQL servers, using run-as-a-program or run-as-a-service. The message which is displayed in a dialog box is "Unable to start Apache server":


I have investigated starting the Apache server further using Procmon (from Sysinternals), and the correct http.exe appears to be located, but the server never attempts to launch. There are no diagnostics in the Apache logs or the Windows event logs. The same problem is encountered when trying to launch the MySQL server too.

Given that the old and new file structures are identical, and that the US servers ran successfully on the old structures, I can only conclude that something in the new underlying OS configuration may be responsible.

Can anyone suggest what the underlying issue may be, or suggest any other additional diagnostics which might help to pinpoint the underlying issue?

I am able to successfully run a XIII Uniform Server, and was planning to migrate from Coral to XIII. However, I am having a separate problem in running the XIII server for which I will raise a separate forum entry, so that option is not really a solution to my immediate problem.

Link to comment
Share on other sites

  • 10 months later...

In the right click properties dialog for windows 7 you need to ensure that it can run as administrator.

Right click apache.exe>properties>compatibility>change settings for all users>run this program as an administrator.

OK your way out of all of that and apache should then be able to run. You might need to do the same with the mysql .exe files too - possibly php but i think as apache calls that it's seen as an apache process.

Link to comment
Share on other sites

  • 1 year later...
  • 7 months later...
  • 1 year later...

This problem is when you try to launch a VirtualBox VM on an M1(ARM)-based MacOS host. VirtualBox is an x86 hypervisor, it is completely unusable on an ARM based host. By all rights it should refuse to install at all, but users sometimes mislead the installer by running it under the MacOS Rosetta2 emulation feature (later releases of VirtualBox 6.1.x detect this scenario and refuse to install). However that emulation is only a facade, a facade which fails thoroughly when the software tries to do something very Intel specific, such as turning on the hardware virtualization features of the supposed x86 CPU.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...