Jump to content
The Uniform Server Community
Sign in to follow this  
elpapo

Apache can not start using Php_7_4_16

Recommended Posts

Hello, I am using Uniform Server ZeroXIV 14.0.3. When I try start apache whith PHP v8.0.3 the server works, but I download plugin Php_7_4_16 and i install it as allways and when tray to start apache it says "apache failed to start"

 

3

apache failed.jpg

apache failed 2.jpg

Share this post


Link to post
Share on other sites

Thanks for pointing it out. I have uploaded a PHP 7.4.16_k to fix this problem.

For an easy fix. Open the core\apache2\conf\extra_us\php74.conf folder and change the 65 to 66 on the following lines.

  LoadFile ${US_ROOTF}/core/php74/icudt65.dll
  LoadFile ${US_ROOTF}/core/php74/icuin65.dll
  LoadFile ${US_ROOTF}/core/php74/icuio65.dll
  LoadFile ${US_ROOTF}/core/php74/icuuc65.dll

to

  LoadFile ${US_ROOTF}/core/php74/icudt66.dll
  LoadFile ${US_ROOTF}/core/php74/icuin66.dll
  LoadFile ${US_ROOTF}/core/php74/icuio66.dll
  LoadFile ${US_ROOTF}/core/php74/icuuc66.dll

Restart Apache and it should now work.

Best Regards,

Sudeep.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...