Jump to content
The Uniform Server Community

Apache Syntax Check on untouched httpd.conf Fails


Recommended Posts

First, I am not new to Uniform Server. I found it in 2009 and have been running ever since then for my Dokuwiki wiki.

However, the time has come to upgrade and I am trying to install Coral 8.8.2 on a Windows 2003 Server platform.

I upgraded the primary wiki server and everything there is fine. I copied it to the backup server (an almost identical server) and cannot get Apache to start. The prior version ran fine.

I tried lots of things and was still unsuccessful at getting Apache started.

So, I cleaned the slate and started with a completely fresh install on another very similar server that has never run Uniform Server. I downloaded the Coral_8_8_2.exe file and ran it. I then immediately ran C:\UniServer\Start_as_program.exe (without making *any* changes).

I selected "Apache Syntax Check" and received this message (I receive the same message when I try to start Apache as a server or a program):


httpd1.exe: Syntax error on line 64 of C:/UniServer/usr/local/apache2/conf/httpd.conf: Cannot load C:/UniServer/usr/local/php/ssleay32.dll into server: This application has failed to start because the application configuration is incorrect. Reinstalling the application may fix this problem.

I tried commenting out that line and it just failed on the next. I have been searching everywhere for a hint at what might be causing this problem and have found nothing.

Any suggestions?


Link to comment
Share on other sites

Looks like I missed a step in the install of this new release. My other systems must have already had the Visual C++ 2008 SP1 Redistributable Package installed.


After installing that the startup went fine. (Tough to figure that out from the problems I encountered though so maybe this will help someone in the future.)


Link to comment
Share on other sites

Glad to see that you found the fix.

When a software package works properly on one system and not on another, it's most likely due to a "helper" package, like these redistributable libraries.

However, finding and fixing the situation can be very tricky.




Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...