Jump to content
The Uniform Server Community
Sign in to follow this  
aducom

virtual host is not working

Recommended Posts

I created two virtual hosts. Strange thing is that whatever url I type, i get the first defined virtual host. If I go to the server, the same issue persists. But if I go to apanel and click on the virtual host then I do get the right website in the correct directory. I'm sure I have forgotten something, anybody?


Best regards,

Albert

Share this post


Link to post
Share on other sites

Obviously there is something not properly configured in your apache configuration.

 

What version are you running? Did you enable vhosts in your httpd.conf?

 

Looks to me as if your vhost config file is disabled hence apache defaults back to the default host /www folder in this case.


<p class="bbc_center"><span style="font-size:12px;"><strong>Yoni</strong></span></p>

Share this post


Link to post
Share on other sites

That's a good hint, i'll look it up. It's a standard US installation in august last year, apache 2.x?


Best regards,

Albert

Share this post


Link to post
Share on other sites

The reason Yoni is asking, is that Coral-8.0.0 does a better job of dealing with vhosts. It's a bit clearer and covers all the bases. If you use it, BE SURE to read the associated docs.

 

Regards,

BobS

Share this post


Link to post
Share on other sites

I'm running orion. How do I enable virtual hosts? I have now:

 

NameVirtualHost *:80

 

 

 

##########VIRTUAL HOST SETUP##########

# WWW.REKENINGVOORU.NL

<VirtualHost *:80>

ServerName www.mydomain.nl

DocumentRoot C:/aducom/Orion/UniServer/wwwrvu

</VirtualHost>

 

 

#====== DEFAULT VIRTUAL HOST ===========

# LOCALHOST

<VirtualHost *:80>

ServerName localhost:80

DocumentRoot C:/aducom/Orion/UniServer/www

 

</VirtualHost>


Best regards,

Albert

Share this post


Link to post
Share on other sites

It's working now. Problem is that I used www and wwwrvu as root directory. As soon as I changed wwwrvu into rvu it simply worked... Got the hint from a collegue, I would never come up with this.


Best regards,

Albert

Share this post


Link to post
Share on other sites

It's working now. Problem is that I used www and wwwrvu as root directory. As soon as I changed wwwrvu into rvu it simply worked... Got the hint from a collegue, I would never come up with this.

Glad you figured it out.

 

There was an issue with the path in the conf file you posted.

 

"DocumentRoot C:/aducom/Orion/UniServer/wwwrvu" wwwrvu was the issue.

 

so you changed it to /rvu and it came up. Of course the folder has to exist in your setup otherwise it will not find it and default back to /www

 

Good job and good luck with your site :)

 

Happy serving.


<p class="bbc_center"><span style="font-size:12px;"><strong>Yoni</strong></span></p>

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...