Jump to content
The Uniform Server Community

UniServer keeps crashing on Vista


Recommended Posts

The title says it all. I'm not doing anything unusual with it just some development work.

I load my page in IE, Chrome, Firefox and UniServer crashes.

[Wed Jul 08 14:06:32 2009] [notice] Apache/2.2.11 (Win32) PHP/5.2.10 DAV/2 configured -- resuming normal operations
[Wed Jul 08 14:06:32 2009] [notice] Server built: Dec 10 2008 00:10:06
[Wed Jul 08 14:06:32 2009] [notice] Parent: Created child process 31480
[Wed Jul 08 14:06:32 2009] [notice] Child 31480: Child process is running
[Wed Jul 08 14:06:32 2009] [notice] Child 31480: Acquired the start mutex.
[Wed Jul 08 14:06:32 2009] [notice] Child 31480: Starting 250 worker threads.
[Wed Jul 08 14:06:32 2009] [notice] Child 31480: Starting thread to listen on port 80.
[Wed Jul 08 14:06:43 2009] [notice] Parent: child process exited with status 3221225477 -- Restarting.

Anybody else getting this?

Link to comment
Share on other sites

That number (3221225477) refers to a general access violation, which means something tried to access a protected memory area. It’s also my way of saying I have no idea what causes it. You state “I'm not doing anything unusual with it just some development work.”


I assume the servers start up with no issues, and only crash when you run your development pages. Can you view static pages without the server crashing? Just wondering if it’s only dynamic pages that kill the server or one specific page.


There is logic behind the questions, a general access violation can be caused by any program more specifically any function within the bundled dlls. Your code may trigger a function that is the cause.


I noticed you are using 4.3-Mona, have you tried another version to see if your code produces a similar result. Trouble is both PHP and MySQL changed through the Mona series hence difficult to point a finger. If your code fails on all four servers it could be Apache that is the culprit however it could equally be a core Vista component.


I found one such issue php_pdo_mysql library using php 5.2.10 reported as a bug.

Note: If you do go looking for bug reports look for both the decimal 3221225477 and hex 0xc0000005 values. Software engineers will report the hex value.


Sorry for the ramble, but there is no easy or quick solution unless someone else has an answer! I could be barking up the wrong tree.


All the best

Ric :)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...