Jump to content
The Uniform Server Community
Sign in to follow this  
Frage

mySql Error #1045

Recommended Posts

I've searched the SQL forums and looked at the other topics regarding this issue, I've attemped those fixes, but have had no luck.

 

The error is

 

#1045 - Access denied for user 'Bill'@'localhost' (using password: YES)

I'm gonna say "Bill" is the username. I'm trying to get SQL 5.1.36 installed. Anybody know of another work around? This is for UniServer 4.3

 

The only change I've done to the sever is upgraded PHP to 5.3.0

 

Thanks :blink:

Share this post


Link to post
Share on other sites

Try running MySQL password restore:

 

UniServer\udrive\plugins\restore_mysql_password\Run.bat

 

All the best

Ric :blink:

Share this post


Link to post
Share on other sites

Thanks, Ric, that did get me back into phpMyAdmin, but it still says I'm running MySql 5.1.35

 

Server version: 5.1.35-community

 

Is that normal? I extracted all the 5.1.36 files into the

 

usr\local\mysql

 

directory and let them overwrite all. Then I did the password recovery.

Share this post


Link to post
Share on other sites

No it should display Server version: 5.1.36-community

 

You need to copy file mysql-noinstall-5.1.36-win32\mysql-5.1.36-win32\bin\libmysql.dll

 

To: UniServer\udrive\usr\local\php\libmysql.dll

 

Let it overwrite the old one.

 

All the best

Ric :)

Share this post


Link to post
Share on other sites

It still seems to be saying the same thing

 

5.1.35-community

 

I also got a default UniServer installation and attempted to upgrade MySql first, that time I got a "Connection was reset" error from the browser. :) (Firefox)

Share this post


Link to post
Share on other sites

Ya! Prior to PHP 5.3.0 you need to use libmysql.dll that comes with PHP. You also need to make a few tweaks in my.cnf.

 

Now add PHP 5.3.0 there are a lot of minor issues that require addressing. It’s probably wise to update phpMyAdmin that said there are several parameters that require changing in its configuration file including a database change.

 

To be honest it’s a circular interaction process, we currently have an Alpha version that addresses these issues however we have a few other issues that require addressing before we go can even go to a beta.

 

My point really is we are working on it, wait a few weeks and you will get a working version without all the heartache.

 

Olajide wants to put a number to a “few weeks” that really is dependent on a core component. To a lesser extent a plugin, Ho Well!

 

All the best

Ric :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...