Jump to content
The Uniform Server Community


  • Content Count

  • Joined

  • Last visited

Posts posted by lekhoi

  1. or just:


    AuthUserFile .htpasswd



    Oh dear, just found it :)


    1. The path to htpasswd file is correct taking the form of /www/docs/.htpasswd depending on where you want to place the .htpasswd


    2. :P :) :D Surprise surprise, the password file is NOT encrypted. That is it would be, password in clear text.





    and thanks to Kevin for giving a hand :-)

  2. Hello, htacess anyone? :P


    I am having a bit of problem with the htaccess basic authentication. I have follow a demo here http://www.he.net/faq/tutorials/htaccess/demo.html


    For the purpose of verifying a working htaccess, I have copy all files word for word like follow:


    .htpasswd (user: john, pass: orange, user: sheri, pass: apple)








    AuthUserFile /www/.htpasswd

    AuthName jdoe_goodstuff

    AuthType Basic

    <Limit GET>

    require valid-user




    I have:


    1. Tested this exact configuration on a live server, changing only the path of the .htpasswd to the server path -- It did works


    2. Tried to adapt this to the uniform server -- Did not work

    3. Debugged by placing htpassword everywhere I could think of, thinking that the path to the pass word file may be the problem -- Did not work


    Thanks in advance for any help.

  3. Find this files and delete them:


    In C:/ find: php.ini

    In C:/Windows or C:/Windows/System32 find: libmysql.dll


    Uninstall any other version of PHP on your computer as you cannot run 2 PHP at the same time unless using them as module/cgi


    Reply if you still get any error...



    Thank you, it was an old version of php dll in the window system folder.


    What I like the most about this is the fact that the .htaccess work very nice. I have tried other installation but could not get it to work. Not to mention the simplicity of running it.


    Thanks again and keep up the good work.

  4. Hello,


    I am trying out uniformserver and very impressed with the simplicity :angry:


    Upon starting I have encounter the follow message



    PHP Startup: gd: Unable to initialize module

    Module compiled with module API=20040412, debug=0,thread-safety=1

    PHP compiled with module API=20041030, debug=0,thread-safety=1

    These options need to match


    The message repeated exactly like above for mysql and sockets


    The Webserver then started and execute PHP like normal until requesting

    for mysql etc. Can some one please help


    Thanks in advance


  • Create New...