Jump to content
The Uniform Server Community
lone

#1045 - Access denied for user 'root'@'localhost'

Recommended Posts

Sorry - back again: now I fixed the trouble with language, and have used the database once, with no problem.

 

Next time:#1045 - Access denied for user 'root'@'localhost' (using password: YES).

How can I get in? Any suggestions out there? I don´t know where to change these passwords, if nescessary. Very annoying, thiought it was all right....

 

:)

regards, Lone

Share this post


Link to post
Share on other sites

Have you changed the root password? Then you need to change it in the phpMyAdmin file too.. uhmm.. diskw\home\admin\www\mysql_password is the file if you're using the UniServer phpmyadmin config file, if not edit the config file instead.

Share this post


Link to post
Share on other sites
Sorry - back again: now I fixed the trouble with language, and have used the database once, with no problem.

 

Next time:#1045 - Access denied for user 'root'@'localhost' (using password: YES).

How can I get in? Any suggestions out there? I don´t know where to change these passwords, if nescessary. Very annoying, thiought it was all right....

 

:)

regards, Lone

2667[/snapback]

 

I had this same problem, what I did was since the config.inc.php reads the password from a file, the mysql_password file and I figured it wasn't reading it in correctly, I hardcoded in the password just changed this on line 76

 

implode ('', file ('../mysql_password'));

 

to whatever password is your root, like so

 

'password';

 

I hope this helps.

Share this post


Link to post
Share on other sites
to whatever password is your root, like so

 

What do you mean by the root password? Do you mean the one in mysql_password? Because I changed it to the one in that one, and it didn't work.

 

Thanks!

 

~ Haz

Share this post


Link to post
Share on other sites
To change the root password, change the password in mysql_password.

 

Do not edit anything else....

2933[/snapback]

 

Hello, I tried everything as above discussed in the forum. Nothing works. I reversed all back to the original = it works.

Then I did step by step change the passwords, as suggested in the Admin Panel 2.0 of the Uniform Server:

 

Security Checklist

Change the username:password for the Admin Panel by editing '/htaccess/home/admin/www/.htpasswd'

Change the username:password for the server (if private) by editing '/htaccess/www/.htpasswd'

Change the root password for mysql by editing '/home/admin/www/mysql_password'

 

I did it step by step.

1) Changed password for Admin Panel = works

2) Changed password for Server = works

3) Changed password for mysql in the file mysql_password = can't log in to phpMyAdmin

3a) Changed then the file config.inc.php by writing the password as discussed above directly in this file = can't log in to phpMyAdmin

3b) However, there are two files config.inc.php. One is in 'home/admin/www/includes', and one in 'home/admin/www/phpMyAdmin'. I presume it is the second one, because the first one look entirely different when opened.

4) I reversed back to root as the password in the file mysql_password, went into phpMyAdmin and tried to change root password directly in MySQL: Details: I clicked in phpMyAdmin on Privileges, clicked on edit of root, input into Change password to my password, clicked OK. Recalled the phpMyAdmin page, but this time could not log in. OK, changed now in the file mysql_password to my password. Reloaded again the phpMyAdmin page = worked!

 

 

SUGGESTION:

Please add to the Admin Panel 2.0 of the Uniform Server as follows:

Security Checklist

Change the username:password for the Admin Panel by editing '/htaccess/home/admin/www/.htpasswd'

Change the username:password for the server (if private) by editing '/htaccess/www/.htpasswd'

Change via phpMyAdmin "http://localhost/apanel/phpMyAdmin/index.php" in MySQL the password for root (username remains root): phpMyAdmin > Privileges > Edit root > Change password

Change the root password for mysql by editing '/home/admin/www/mysql_password'

 

Does this sound sensible?

Share this post


Link to post
Share on other sites

Hi Guys,

 

I just installed the latest version of Uni Server (ver. 3.3) and I am also getting error #1045. I tried everything that was suggested in the previous posts but I still can't connect. I have no idea what the problem could be.Any help would be welcomed.

 

Thanks in advance

Share this post


Link to post
Share on other sites

Hi guys,

 

I don't know what I did but I fixed the problem and phpMyAdmin is working now. I just ran an older version of Uni Server to see if i get the same problem and I did. Then I ran the latest version again and it worked. Software works in mysterious ways. :D

 

Ashmon

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...