Jump to content
The Uniform Server Community
stephanj

InnoDB Support with Uniform Server??

Recommended Posts

Hi all,

 

Great product. I can't seem to get InnoDB support with Uniform Server 3.3 (I am using XP). For example, When I create a script below:

 

CREATE TABLE prime_minister

(

pm_name varchar(12) NOT NULL PRIMARY KEY,

birth_yr smallint NOT NULL,

yrs_served numeric(7,2) NULL,

death_age smallint,

state_born varchar(3) NULL,

state_rep varchar(3) NOT NULL

 

)TYPE=InnoDB;

 

CREATE TABLE pm_recreation

(

pm_name varchar(12) NOT NULL ,

recreation varchar(15) NOT NULL ,

PRIMARY KEY(recreation,pm_name),

INDEX(pm_name),

CONSTRAINT pm_name_fk FOREIGN KEY (pm_name) REFERENCES prime_minister(pm_name)

)TYPE=InnoDB;

 

Uniform server DOES NOT allow InnoDB support. The table defaults automatically to MyISAM.

 

You don't have the option to create InnoDB via PHP admin.

 

Is there a problem with Uniform Server and InnoDB??

Share this post


Link to post
Share on other sites
You may have to tweak the MYSQL Configuration File in the /usr/local/mysql/bin/ folder.

2570[/snapback]

 

 

Thanks............... BUT what is the name of the configuration file??

Share this post


Link to post
Share on other sites
Thanks...............  BUT what is the name of the configuration file??

2581[/snapback]

 

 

I HAVE FOUND IT the file W:\usr\local\mysql\bin\my-small is the configuration file

 

I edited as follows (NOTE the comments) to enable InnoDB and it works

 

Thanks so much for a great product!!

 

# Uncomment the following if you are NOT using BDB tables

#skip-bdb

 

# Uncomment the following if you are NOT using innodb tables

#skip-innodb

 

# Uncomment the following if you are using Innobase tables

innodb_data_file_path = ibdata1:100M

innodb_data_home_dir = /usr/local/mysql/data/

innodb_log_group_home_dir = /usr/local/mysql/data/

innodb_log_arch_dir = /usr/local/mysql/data/

set-variable = innodb_mirrored_log_groups=1

set-variable = innodb_log_files_in_group=3

set-variable = innodb_log_file_size=5M

set-variable = innodb_log_buffer_size=8M

innodb_flush_log_at_trx_commit=1

innodb_log_archive=0

set-variable = innodb_buffer_pool_size=16M

set-variable = innodb_additional_mem_pool_size=2M

set-variable = innodb_file_io_threads=4

set-variable = innodb_lock_wait_timeout=50

Share this post


Link to post
Share on other sites

Hi mates:

 

I have tried the same solution as stephanj, but is not working in my case (Windows XP, Uniserver 3.3). What might I am doing wrong?

 

Please, setephan, could you confirm if that solution worked for you?

Share this post


Link to post
Share on other sites

hmm, please check once more to make sure everything is set correctly. Make sure you do not have another MySQL running in the background...

Share this post


Link to post
Share on other sites

That's true. I have been trying to enable INNODB but I had not luck. In the log file it reported that there was a problem with the size of the file ibdata1. So I have deleted these files (ibdata1, ib_logfile1, ib_logfile0) and let MySQL to rebuild it. And voilá. INNODB is enabled in my Uniform Server.

 

Thanks guys. Uniform Server Rocks!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...