Jump to content
The Uniform Server Community
Sign in to follow this  
angus203

cannot open phpMyAdmin

Recommended Posts

cannot open phpMyAdmin from ver3.3

please improve?

 

and new version has not auto open admin apanel?

i feel no convenient.

 

Warning: require_once(./lang/chinese_traditional-big5.inc.php) [function.require-once]: failed to open stream: No such file or directory in W:\home\admin\www\phpMyAdmin\libraries\select_lang.lib.php on line 307

 

Fatal error: require_once() [function.require]: Failed opening required './lang/chinese_traditional-big5.inc.php' (include_path='.;/usr/local/PHP/includes;/usr/local/PHP/pear') in W:\home\admin\www\phpMyAdmin\libraries\select_lang.lib.php on line 307

Share this post


Link to post
Share on other sites
We do not always get what we want in life

 

Everything in 3.3 was done for a reason. If you get the language error in phpMyAdmin, download the version from their site and get the language file. Simple as that. We cannot add all the languages because they are about 2+MB

 

We removed the starting > admin panel because it is also a security risk.... starting the server and it going directly to the admin panel... I'm sure you have time to type in /apanel/ to the end of http://localhost.

Share this post


Link to post
Share on other sites

A solution to languages problems regarding access to phpAdmin:

 

download the complete phpMyAdmin from

http://www.phpmyadmin.net/home_page/index.php

 

They include alle the languagefiles in the download. Copy and paste the relevant languagefiles into folder: Uniform Server\Uniform Server\diskw\home\admin\www\phpMyAdmin\lang

 

It works

regards, Lone

Share this post


Link to post
Share on other sites

Please don't think i am lashing at you... its not that we do not know how to fix it or what the problem is, its just that adding the damn language files adds more size (about 3MB more) to the server!

 

We are all about cutting size.... its our fault, next time we will just delete the codes for those languages.

 

Thanks. :) :)

 

*hope we still friends* :)

Share this post


Link to post
Share on other sites

Hehe it's pretty easy replacing the phpmyadmin anyway, right... I have at least a couple of versions installed here.. and editing it isn't all that bad anyway, just add the langfiles and edit the diskw\home\admin\www\phpMyAdmin\libraries\select_lang.lib.php

$available_languages = array(
   'af-iso-8859-1'     => array('af|afrikaans', 'afrikaans-iso-8859-1', 'af'),
   'af-utf-8'          => array('af|afrikaans', 'afrikaans-utf-8', 'af'),
   'ar-win1256'        => array('ar|arabic', 'arabic-windows-1256', 'ar'),
// [etc usw osv]
   'zh-utf-8'          => array('zh|chinese simplified', 'chinese_simplified-utf-8', 'zh')
);

- or copy over the file from latest PMA, as I recall it hasn't changed.

 

I'm totally on Olajides side in this, they're big and it's bloat. :)

Share this post


Link to post
Share on other sites

In final 3.3 version there is only english language pack for phpmyadmin.

 

I think that you should include the language packs to it of languages which are included in (translated and prepeared for) Admin Panel

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...