Jump to content
The Uniform Server Community
desbest

I cannot choose the modules on PHP 7.2

Recommended Posts

I'm using Uniform Server with PHP 7.2 and upon running a php page I made I get this error.

Fatal error: Uncaught Error: Call to undefined function mb_detect_encoding()

When I try to enable the mbstring php module (and other modules) through the graphical user interface I get this.

47420194_cantchoosemodules.png.d7f1473b6c5173c773d66c4176b1ac73.png

So when I do it manually, my php_production.ini looks like this. I have used Uniform Server to select that php settings file.

extension=gd2
extension=mbstring
extension=exif      ; Must be after mbstring as it depends on it
extension=mysqli

So why do I still get the error if I have enabled the modules manually via the text editor?

 

Share this post


Link to post
Share on other sites

It's not just mbstring module that I can't load, I also can't load the mysqli module on PHP 7.2 for Uniform Server.

Please help

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...