Jump to content
The Uniform Server Community
Chris Lees

Apache fails to start with LetsEncrypt SSL certificates

Recommended Posts

I have used Certbot for Windows to generate LetsEncrypt certificate files. This process has worked correctly, and I've checked the MD5 hash using openssl and they match too.

However, when I assign them to the vhost in the Apache conf file and try to start Apache, I get the message "Apache failed to start". My SSL directives in the VirtualHost section of the conf file are:

 SSLCertificateChainFile "${US_ROOTF}/Certbot/live/dev.harc.uk/chain.pem"
 SSLCertificateFile "${US_ROOTF}/Certbot/live/dev.harc.uk/fullchain.pem"
 SSLCertificateKeyFile "${US_ROOTF}/Certbot/live/dev.harc.uk/privkey.pem"
 SSLEngine On

When I get the error message it is in a popup. However, nothing is written to the log files in c:\UniServerZ\core\apache2\logs - in fact if I delete all the log files and try to start Apache, no log files are even created.

I have non-SSL virtual hosts working perfectly well in this server. I am also using port 8080 for http and 8081 for https.

Any ideas how I can debug this problem?

Thanks in advance.

Share this post


Link to post
Share on other sites

Hello,

Did you find a way to fix this?
I'm having the same problem and if you could share the solution, I would really appreciate it!

Thank you!

Share this post


Link to post
Share on other sites

Ok.. This has been something that I have been thinking about implementing into UniformServer for some time now. I just have not time to do the research work to implement it, after I took over the UniformServer maintenance. 

Can you please DM me so that we can work together and implement the Let's Encrypt SSL certs into UniformServer.

Thanks

Share this post


Link to post
Share on other sites

Sudeep,

I realize it has only been a couple of weeks, but have you been able to find time to start looking into the LET's Encrypt integration?
I'd be interested in your progress.  I use Let's Encrypt to manual insert certs into my sites hosted elsewhere.  However, I have used UniformServer for many years for local web services and now find a need to add certs to these sites as well.   I am just looking into this now, but if you've made any progress, I'd rather not duplicate efforts, or at least leverage your research.

Thanks for any insights.

Brian

Share this post


Link to post
Share on other sites

@Bannockburn Not yet.. Right now more focused on getting the version with PHP8 into the wild. Will take up the Let's Encrypt SSL integration after that. I know it has been a long pending item on my radar. Just not getting the time to focus on the development aspect of things. Thank you for your patience.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...