Jump to content
The Uniform Server Community
Len Jacobson

'laptop-test-server' Created -- Can't Open Test Server From Browser

Recommended Posts

On my new laptop (running Windows 10 Pro), I have created a test server.  It appears to be working correctly with one exception -- I cannot enter "laptop-test-server" into the URL field of my browser and bring up the test server.  When I do that, the browser brings up a search engine that shows me hits for the search on "laptop-test-server".

I have modified the 'hosts', 'httpd.conf', and 'httpd-vhosts.conf' files as I have always done.  But this time it doesn't work.

I have attached the 'hosts' file in its entirety.  I have attached just the last section of the 'httpd.conf' file, because the rest of that file is exactly the original content of the file.  And I have attached the 'httpd-vhosts.conf' file.

Any suggestions will be greatly appreciated.

Len Jacobson

My_hosts My_httpd.conf My_httpd-vhosts.conf

Share this post


Link to post
Share on other sites

Len,

You should be able to add in Virtual Hosts using the Uniformserver interface itself.. It will automatically do all the configuration for you.

Apache->Apache Vhosts->Create Apache Vhost

If it still does not work, I will take a deeper look into it.

 

Share this post


Link to post
Share on other sites

In all my years of using UniServer, I have always had my test server located at:

   C:\UniServerZ\www\TestServer

and I have called my test server:

   laptop-test-server

When I executed the Apache->Apache Vhosts->Create Apache Vhost as you suggested, it asks for the Root Folder Name.  I entered "www\TestServer", which it said was an incorrect format.  Entering just "TestServer" was accepted.

But it won't accept "laptop-test-server" as the Server Name.  It says it is an "incorrect format".

Please advise.

And thank you so very much for trying to help me!!!

Share this post


Link to post
Share on other sites

Len,

Maybe the solution is simpler that I thought it was.. Have you tried http://laptop-test-server instead of just laptop-test-server in your browser URL? I tried this out and for some reason, the first time I typed in laptop-test-server, it took me to the search page, but after I used http://laptop-test-server it took me to the correct page and interestingly from then on, even typing laptop-test-server without the http:// worked correctly.

Even so, setting up a virtual host would be better than creating a folder in www, when you want to use the same instance of UniformServer for multiple projects.

What I do is to have Uniformserver set up the virtual host folders in vhosts and then go in and update the http-vhosts.conf file to have a latptop-test-server.localhost type subdomain for each of the vhosts I set up. That way I can have multiple projects each with a different subdomain running off the localhost

This would leave the http://localhost tied in with the main  www as well.

Share this post


Link to post
Share on other sites

Sudeep,

It would never have occurred to me to try "http://laptop-test-server".  And when I did, it worked exactly as you described.  Even entering "laptop-test-server" thereafter worked as you said it would.  Strangely, it doesn't seem to work for all of my several websites that are in sub-directories of C:\UniServerZ\www\TestServer.

I wish I understood why this version of UniServerZ has this issue when earlier versions did not have the problem.

I must admit to you that I do not understand how to apply your advice in your second-to-last paragraph.  Could I trouble you to help me further with this?  In my first submital in this thread, I included copies of the pertinent files.  If you could help me to correct the contents of those files, I would be very grateful.  Or if you help me to use the Apache->Apache Vhost->Create Apache Vhost process that you suggested in your first response, that would be great, too.

Thank you very much.

Len

Share this post


Link to post
Share on other sites

I don't think it is UniformServer that is the problem, but more of how the browser handles the query when typed into the URL. Should it treat it as text that it needs to search for, or should it treat it as a URL to get the web page? UniformServer is not part of this process.

If you have Admin rights the Apache->Apache Vhost->Create Apache Vhost process would also work as well. When you set up a vhost, Uniformserver adds in the 127.0.0.1     Sitename to your hosts file automatically.

For eg., if you set up len.com as the sitename on a vhost, and the folder is len-server, then typing in http://len.com in your browser should server the pages in the vhosts/len-server folder.

UniformServer sets this up for you automatically.

 

 

Share this post


Link to post
Share on other sites

Sudeep,

Thank you again for your suggestions.  One thing that I am sure was obvious to you but not to me is that using the Apache->Apache Vhost->Create Apache Vhost requires that the test server name have ".com" following it (as in "laptop-test-server.com").  I will try that.

You've been a great help to me and I appreciate it very much!

Thank you.

Len

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...