Jump to content
The Uniform Server Community
jandrew

Windows 10 2018 Upgrade version 1803 stops apache

Recommended Posts

I'm an old dog (75) not very good at learning new tricks.

I still use Coral_8_0_0 to create my WAMP server and am comfortable with it, so please don't tell me to upgrade to 13_3_2_ZeroXIII.

I have tried that and haven't yet worked out how to have several websites in the vhosts folder and get to them via the localhost.

I promise that I will sort that out - but, meanwhile, I have another more pressing problem:

 

I am running Windows 10 on a desktop computer, and I have Apache running as a service and I can :

1. Stop it when I like and restart it when I want;

2. Maintain 13 websites in the vhosts folder;

3. Look at each site via the localhost.

 

A few weeks ago the Windows 10 OS was upgraded for April 2018 to version 1803, and my setup stopped working :

1. I could not stop or start apache either as a service or as a programme;

2. I could not look at my local sites via localhost.

 

This was really annoying as I update most of these sites on a daily/weekly basis.

Also Dreamweaver did not work properly as it could not access the local site.

 

I uninstalled the version 1803 upgrade and - magic - Apache and Dreamweaver and the localhost worked perfectly again.

 

HOW CAN I OVERCOME THIS PROBLEM ?

 

I sync everything to my laptop which also has windows 10 (not yet upgraded) where everything works as I like.

Today - the 1803 upgrade arrived and I installed it to see what would happen.

Alas - Apache and localhost stopped (like on the desktop machine) so I uninstalled the upgrade and everything reverted back to normal.

 

I would like to solve this problem before I get stuck into sorting out the latest version of WAMP.

 

Any help will be gladly received. Thanks in advance.

Share this post


Link to post
Share on other sites

Solution:

  1. Start/Run SERVICES.MSC
  2. Locate service "World Wide Web Publishing Service" and click its gearwheel
  3. On the "Properties" dialog, Change "Startup Type" to "Disabled", click "Stop" and "OK"

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...