Jump to content
The Uniform Server Community
Sign in to follow this  
richfieldmall

How to access vhosts over LAN?

Recommended Posts

P.S. I see tutorials on altering Apache files "by hand" but am concerned this could affect the Uniform Server's performance, or that I will confuse the /www and /vhosts in Uniform server's setup (vs. the seemingly random naming of other wamp/xampp/what have you setups out there), or there is already something in the interface to do this, which I am too much of a newbie to recognize as such.

Any helps, including URLs, are most appreciated.

Share this post


Link to post
Share on other sites

Hellow, try to do like this

 

For example: Your server hosted on IP: 192.168.0.10

 

Enable virtual host in httpd.conf

##====== VIRTUAL HOST ===========
#To enable uncomment next line
Include conf/extra/httpd-vhosts.conf

Edit httpd-vhosts.conf

# Case 1 : if Access from any local IP  though 192.168.0.xx by taping http://192.168.0.10 on browser 
<VirtualHost _default_:${AP_PORT}>
	ServerAdmin admin@localhost
	DocumentRoot ${US_ROOTF}/vhosts/my-website
	ServerName ${US_SERVERNAME}
	ErrorLog  logs/my-website-error.log
	CustomLog logs/my-website-access.log common
	
	<Directory "${US_ROOTF}/vhosts/my-website/">
		Options Indexes Includes
		AllowOverride All
		Require all granted	
			
	</Directory>	
</VirtualHost>


# Case 2: If access from any local ip though a virtual server's name
#         For each local client,
#  	  You need to bind your virtual server's name with your server IP in Windows hosts file
#	  Open Notepad as administrator and load C:\Windows\System32\drivers\etc\hosts
#         Add after the last line
#         192.168.0.10	my-website 
#         Now each client from local ip 192.168.0.xx can access on browser by http://my-website

<VirtualHost *:80>
	ServerAdmin admin@localhost
	DocumentRoot ${US_ROOTF}/vhosts/my-website
	ServerName my-website
	ErrorLog  logs/my-website-error.log
	CustomLog logs/my-website-access.log common
	
	<Directory "${US_ROOTF}/vhosts/my-website/">
		Options Indexes Includes
		AllowOverride All
		Require all granted	
			
	</Directory>	
</VirtualHost>

Restart your Apache.

Now you can access to your site from your LAN by server IP (

 

Hope it will help even to late ;)

Share this post


Link to post
Share on other sites

Hellow, try to do like this

 

For example: Your server hosted on IP: 192.168.0.10

 

Enable virtual host in httpd.conf

##====== VIRTUAL HOST ===========
#To enable uncomment next line
Include conf/extra/httpd-vhosts.conf

Edit httpd-vhosts.conf

# Case 1 : if Access from any local IP  though 192.168.0.xx by taping http://192.168.0.10 on browser 
<VirtualHost _default_:${AP_PORT}>
	ServerAdmin admin@localhost
	DocumentRoot ${US_ROOTF}/vhosts/my-website
	ServerName ${US_SERVERNAME}
	ErrorLog  logs/my-website-error.log
	CustomLog logs/my-website-access.log common
	
	<Directory "${US_ROOTF}/vhosts/my-website/">
		Options Indexes Includes
		AllowOverride All
		Require all granted	
			
	</Directory>	
</VirtualHost>


# Case 2: If access from any local ip though a virtual server's name
#         For each local client,
#  	  You need to bind your virtual server's name with your server IP in Windows hosts file
#	  Open Notepad as administrator and load C:\Windows\System32\drivers\etc\hosts
#         Add after the last line
#         192.168.0.10	my-website 
#         Now each client from local ip 192.168.0.xx can access on browser by http://my-website

<VirtualHost *:80>
	ServerAdmin admin@localhost
	DocumentRoot ${US_ROOTF}/vhosts/my-website
	ServerName my-website
	ErrorLog  logs/my-website-error.log
	CustomLog logs/my-website-access.log common
	
	<Directory "${US_ROOTF}/vhosts/my-website/">
		Options Indexes Includes
		AllowOverride All
		Require all granted	
			
	</Directory>	
</VirtualHost>

Restart your Apache.

Now you can access to your site from your LAN by server IP (

 

Hope it will help even to late ;)

i did as you said but still doesnt work for me. some one??

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...