Jump to content
The Uniform Server Community
shoolz

#1045 - Access denied (Potential Workaround)

Recommended Posts

Problem:

If you have changed the root password, phpMyAdmin will give you the following error message :

"#1045 - Access denied for user: 'root@localhost' (Using password: YES)"

 

I have been in contact with Olajide, and he has kindly informed me:

 

"ok, i found the problem and its a mistake from our part.... MySQL 5 has improved the emysql.user table and chnaged some things around so the mysql.user table in Uniform 3.3 is still using the old MySQL 4.1 way... thats the problem... If you read the /usr/local/mysql/data/*err file, you will notice it...

 

It wont let you change the password because of this.. if you can wait a month for the next version it should be fixed...

 

To fix it yourself, download MySQL 5.1.17 from MySQL.COM and copy over the mysql.user table, then edit the mysql_password file and put the default mysql passpord in it. Try root or nothing at all... i'm not sure what the default mysql password is...."

 

I have not tried the work-around and will wait until this is fixed, hopefully in 3.3a.

 

Congratulations Uniform Server team on being so responsive to your users! Special thanks to Olajide. "Do you live on your computer?" :lol:

Share this post


Link to post
Share on other sites

Couldn't find MySQL 5.1.17 there.. the newest was 5.1.11 ._o

almost finished downloading that... will post results :rolleyes:

 

EDIT: uhh.. I'm lost :S

Share this post


Link to post
Share on other sites

Hi Folks,

 

I have a general MySQL problem. It's not just PHPMyAdmin -- it seems to be more the way MySQL is setup (?)

 

Here is what I can confirm is working:

 

* I can add users

* I can add databases

* I can import SQL

 

Here is what I can confirm is not working:

 

* I cannot add user rights to databases (i.e. cannot modify a user to give him rights to a DB)

* I cannot drop databases

 

I started with the root password as standard and when that didn't work, I changed it. Still didn't work.

 

I have followed all the instructions here: http://brionews.com/alt/sql-error-1045-workaround.txt.

 

Still no luck.

 

I have tried with the MySQL official SQL tools -- specifically, MySQL Query Browser -- and it doesn't work there, either.

 

For example:

 

CREATE DATABASE 'mydb'; // database is created

DROP DATABASE 'mydb'; // database cannot be dropped, error given as: "Access denied for user 'root'@'localhost' to database 'mydb'

 

That's too weird. I guess I could now go ahead and install a fresh copy of MySQL, but having spent an hour on this I'm going back to Uniform Server 3.3 for now :=)

 

Cheers,

 

 

Ed

Share this post


Link to post
Share on other sites

Ok... this is not a problem. It works perfectly, but you are doing soemthing wrong.

 

A. Download a NEW copy of 3.4-Sluger

B. Start the server using Server_Start.bat

C. Go to the Admin Panel http://localhost/apanel

D. Click Run MySQL

E. Go to phpMyAdmin

F. Create Database

G. Drop Database

 

And you will see it works. If you are trying to change the MySQL root password, in the Admin Panel, look for "MySQL Server Configuration" change the password there and after changing the password, STOP the SERVER with Stop.bat and then start the server over again and it should start using the password you change it too.

 

Uniform Server is different than other WAMP Servers. What makes us different is that we are mobile and in order to be mobile, we have to be flexible. The password is not hardcoded into MySQL but saved to a file and ...

 

Just do it and it should work perfect. :D

 

PS: DO NOT EVER CHANGE THE MYSQL PASSWORD FROM PHPMYADMIN UNLESS YOU KNOW WHAT TO DO!

Share this post


Link to post
Share on other sites

If you still need further support, check out the newly pinned topic in the MySQL Support Forum.

 

http://forum.uniformserver.com/index.php?s...view=getnewpost

 

Hi Olajide!

 

Thanks for the really fast reply, still no luck though.

 

Did exactly as you suggested:

 

A. Download a NEW copy of 3.4-Sluger CHECK

B. Start the server using Server_Start.bat CHECK

C. Go to the Admin Panel http://localhost/apanel CHECK

D. Click Run MySQL CHECK

E. Go to phpMyAdmin CHECK

F. Create Database CHECK

G. Drop Database FAILED

 

I then checked out the other thread and saw that, as said there, the DROP privilege was not set.

 

OK, so I go to "Privileges" and click on the root account and check the "DROP" box.

 

I then click "Go" and get:

 

Error

SQL query:

GRANT ALL PRIVILEGES ON * . * TO 'root'@'localhost' WITH GRANT OPTION MAX_QUERIES_PER_HOUR 0 MAX_CONNECTIONS_PER_HOUR 0 MAX_UPDATES_PER_HOUR 0 MAX_USER_CONNECTIONS 0;

MySQL said:
#1045 - Access denied for user 'root'@'localhost' (using password: YES)

 

:D

 

Note that Metaltailz suggestion

 

You will then see a list of all the privleges available to that user, just change the value of Drop_priv to yes.

 

Thus did not work.

 

I'll have a go at installing this at home -- maybe it's the office system that's shot.

 

Cheers,

 

 

Ed

Share this post


Link to post
Share on other sites

No no.... That method wont work... It will be like granting permission to something you dont have permission for. What you have to do is go into the "mysql" database using phpMyAdmin.

 

In the user table, change Drop_priv to Y.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...