Jump to content
The Uniform Server Community
curly nostrill

register globals

Recommended Posts

so much learning to get...

 

What is the best way to turn off register globals? I see at the PHP site that one can put a flag or entry in .htaccess stating "php_flag register_globals off".

 

or should I do this in php.ini. I'm using the php.ini included in UniS3.2a.

 

or should I do both? or something completely different...?

 

I get the warning in the setup for jinzora and this appears to be a serious issue everywhere else except, maybe, in a development env.

 

I'm trying to set up the server to serve a few pages from a walled garden on my local network to go with my ZoneCD setup and/or to run jinzora and I don't want to screw anything up (anymore).

 

I'm using uniserver 3.2a on winXP pro sp2.

 

Thanks,

 

curly

Share this post


Link to post
Share on other sites

Though it is not really needed for you to turn it Off when using Jinzora, as i also do with it On and have no problems, the best way to do it is to turn it Off in the php.ini file.

 

If you need it else where but want it off in Jinzora, then turn it Off using the .htaccess method.

 

Thanks.

Share this post


Link to post
Share on other sites

switching register globals to Off restarting the server stops uniform server working properly with the error

 

 

Warning: gethostbyaddr() [function.gethostbyaddr]: Address is not in a.b.c.d form in W:\home\admin\www\includes\config.inc.php on line 18

 

it didnt seem to do it before when i changed it. I ideally want to mirror my server config, and this has it set to Off

 

thanks

 

:)


http://www.landed.at - a travel forum, please come along and post something about a destination you know.

Share this post


Link to post
Share on other sites

I have never come across any code in US 3.5 that requires register globals to be On hence switching it Off is not a problem, US 3.5 works fine. :)

 

The message you receive is only a warning; it looks like that code (line 18) is no longer used try commenting out the line.

 

You state “stops uniform server working properly” is it just the warning you are concerned with or does it really stop US working correctly?

 

(Known bug)

The only bug I have ever found in 3.5 is in config.inc.php on line 26 while you are in this page change the line from:

$drive="$pathArray[0]/$pathArray[1]";

to

$drive="$pathArray[0]";

 

This code is executed only when using a virtual drive letter other than the default “W” hence majority of users will never see a problem.

 

All the best

Ric :)

Share this post


Link to post
Share on other sites

Thanks, maybe this will go away in the next release ?

 

I guess in the sense that I couldnt get to the admin panel or phpmyadmin, was why it wasnt working. I have left Globals on for now, but will try commenting that line out as suggested.

 

Doing that now actually to save me finding this post later :)

 

so far commenting that line out works..

 

 

thanks


http://www.landed.at - a travel forum, please come along and post something about a destination you know.

Share this post


Link to post
Share on other sites

Well quick dirty fixes always come back to haunt. This is no exception I think the combined bug fix see Wiki will resolve this:

 

http://wiki.uniformserver.com/index.php/Bu..._config_inc_php

 

All the best

Ric :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...